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VMware Run Direct VM fails to boot: "Operating System not found"

May 16, 2025

Product Version

AhsayOBM: 7.9.0.0 to 7.17.x

Operating System

Windows

Symptom

When performing a VMware virtual machine restore with Run Direct, if the the backup destination storage is located on a network drive and Auto power on after Run Direct is running is selected. AhsayOBM will report the restoration process as completed successfully.

vmware-rundirect-fails-to-boot-operating-system-not-found-01.png

However, upon further verification from the vSphere client, the restored VM cannot boot up with the following error message:

Operation System not found

vmware-rundirect-fails-to-boot-operating-system-not-found-02.png

Cause

The AhsayOBM NFS service cannot access the VMware backup files on the network backup destination.

Starting from AhsayOBM version 7.9.0.0, the AhsayOBM NFS service used for VMware Run Direct restore is an independent Windows service, which by default is started as Local System account. Therefore, the service does not have access to network resources (e.g. the AhsayOBM NFS service does not have sufficient permission to access the VMware backup files on network drive).

Although the guest VM cannot boot up properly, it is still possible to perform a migration of the guest to the VMware Host. After which, the guest VM will boot up normally.

Resolution

To resolve the issue, modify the Log on setting of the Ahsay Online Backup Manager NFS Service to an account with sufficient permission to access the network backup destination.

  1. Under Control Panel, open Administrative Tools then Services.
  2. Right click on Ahsay Online Backup Manager NFS Service, select the Log on tab.
  3. Select the This Account option.
  4. Enter the login credentials of an account with sufficient permission.
  5. Restart the service afterwards.