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Error: Invalid sClientid shown after selecting Google Drive restore

May 16, 2025

Product Version

AhsayACB / AhsayOBM: 7.5.0.0 to 7.17.x

Operating System

All Platforms

Symptom

When performing a restore on AhsayOBM/AhsayACB the following error is shown after selecting Google Drive backup destination "[GDriveManager.getAppName] Invalid sClientid: null".

invalid-sclientid-in-google-drive-restore-01.png

Cause

The Google Drive authentication token has expired. This could be caused by long periods without regular use, i.e. no regular backups or restore from the backup destination.

Resolution

To resolve this problem, refresh the Google Drive authentication token:

  1. On the AhsayOBM/AhsayACB UI
  2. Go to [Backup Sets] and select the affected backup set.
  3. Click on the Google Drive Destination.

    invalid-sclientid-in-google-drive-restore-02.png

  4. Click on the Refresh button.

    invalid-sclientid-in-google-drive-restore-03.png

  5. A web browser session will be launched. Enter the Google Drive login credentials.

    invalid-sclientid-in-google-drive-restore-04.png

  6. Copy the authorization code for Google Drive.

    invalid-sclientid-in-google-drive-restore-05.png

  7. Paste the authorization code back to AhsayOBM/AhsayACB and click OK.

    invalid-sclientid-in-google-drive-restore-06.png

  8. After the authorization code has been verified. Click OK to continue.

    invalid-sclientid-in-google-drive-restore-07.png

  9. Click Save to update the backup set.

    invalid-sclientid-in-google-drive-restore-08.png