AhsayACB Continuous backup hangs with ProgramData folder as backup source
May 30, 2025
Product Version
AhsayACB / AhsayOBM: 7.3.2.0 - 7.5.0.0
Operating System
Windows
Symptom
Continuous backup job for backup set with "ProgramData" folder selected as backup source is randomly hanging.
Further checking on the Continuous Backup Log (e.g. cdp.log) on the affected client computer, the following error message is displayed for the backup job that hang:
[YYYY/MM/DD hh:mm:ss] [erro] [CB.ErrorStream] com.ahsay.afc.bfs.cloud.d: [BackupSetIndex.updateBackupFile] sBackupJob=Current bf=[BackupFile][ClientPath=C:\ProgramData\Application Data\AhsayOBM\log\cdp.log.10][Type=F][BackupByJob=YYYY-MM-DD-hh-mm-ss][FileSystemObjectType=2]
...
[YYYY/MM/DD hh:mm:ss] [erro] [CB.ErrorStream] Caused by: com.ahsay.afc.db.bdb.f: [BlockDB.update] Cannot find key to update (Temp\backupset_id\OBS@backupset_id\index\index.b2b).
This issue may also affect manual or scheduled backup job for the same backup set.
Cause
This is a known issue with AhsayOBM / ACB version 7.3.2.0 - 7.5.0.0.
Resolution
To resolve the issue, patch the AhsayOBM / ACB application to version 7.7.0.0 or above.
This issue affects a legacy version of our software. We strongly recommend upgrading to the latest AhsayCBS and AhsayOBM release (v9.15.0.0, as of 2025/May/15) for improved performance, compatibility, and security.
Contact us to confirm your license is valid to upgrade.