Skip to main content

AhsayOBM cannot back up Google Drive items with underscore in name

June 2, 2025

Product Version

AhsayCBS / AhsayOBM: Pre-7.17.0.30

Operating System

Windows

Symptom

When performing a Cloud File backup for data on Google Drive, the following error message is displayed on the backup client interface, or in the backup report:

This issue will only affect files and folders on Google Drive with name containing underscore ( _ ) (also called underline) character.
No.TypeTimestampLog
*info...Start [ Windows platforms (computer), AhsayOBM pre-7.17.0.30 ]
*.........
*info...Finished running pre-commands
*erroYYYY/MM/DD hh:mm:ss[New File] File="backup_source/path_with_slash_character" Error="com.ahsay.afc.bfs.cloud.o: [CloudFileSystem.createFile] Parent directory 'backup_source/path_with_slash_character' does not exist
at com.ahsay.afc.bfs.cloud.y.a(Unknown Source)
at com.ahsay.afc.bfs.cloud.v.a(Unknown Source)
at com.ahsay.cloudbacko.pc.a(Unknown Source)
at com.ahsay.cloudbacko.pc.a(Unknown Source)
at com.ahsay.afc.bfs.cloud.v.a(Unknown Source)
at com.ahsay.obx.core.backup.file.d.a(Unknown Source)
at com.ahsay.obx.core.backup.file.L.run(Unknown Source)
at com.ahsay.afc.util.h$1.run(Unknown Source)
at java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source)
at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)
at java.lang.Thread.run(Unknown Source)" 
*.........

Cause

This is a known issue with AhsayCBS / AhsayOBM version pre-7.17.0.30.

For files and folders on Google Drive with name containing any underscore ( _ ) (also called underline) character, for example:

name_with_underscore

The underscore ( _ ) characters are returned as slash ( / ) characters (which are incorrectly interpret as path separator):

name/with/underscore

Resolution

To resolve the issue, patch the AhsayCBS / AhsayOBM application to version 7.17.0.30 or above.

This issue affects a legacy version of our software. We strongly recommend upgrading to the latest AhsayCBS and AhsayOBM release (v9.15.0.0, as of 2025/May/15) for improved performance, compatibility, and security.

Contact us to confirm your license is valid to upgrade.