Microsoft Exchange DAG backup fails with "[MigrateV6Index]" error
June 3, 2025
Product Version
AhsayOBM: 7.3.2.0 - 7.5.0.2
Operating System
Windows
Symptom
For MS Exchange DAG server backup set created by AhsayOBM version 6, after upgrading the client application to version 7.3.2.0 - 7.5.0.2, when performing a MS Exchange DAG server backup, the following error message is received in the Backup Job Logs :
[YYYY/MM/DD hh:mm:ss] [erro] Unable to do backup, Error= [MigrateV6Index.migrateIndex] Failed to migrate v6 index
[YYYY/MM/DD hh:mm:ss] [info] Start Microsoft Exchange backup
[YYYY/MM/DD hh:mm:ss] [info] Start creating Shadow Copy Set...
[YYYY/MM/DD hh:mm:ss] [info] Shadow Copy Set successfully created
[YYYY/MM/DD hh:mm:ss] [info] End Microsoft Exchange backup
...
[YYYY/MM/DD hh:mm:ss] [erro] null
[YYYY/MM/DD hh:mm:ss] [erro] Backup completed with error(s)
This issue will not affect MS Exchange DAG server backup set created by AhsayOBM version 7.
Cause
This is a known issue with AhsayOBM 7.3.2.0 - 7.5.0.2.
Resolution
To resolve the issue, patch the AhsayOBM application to version 7.7.0.0 or above.
This issue affects a legacy version of our software. We strongly recommend upgrading to the latest AhsayCBS and AhsayOBM release (v9.15.0.0, as of 2025/May/15) for improved performance, compatibility, and security.
Contact us to confirm your license is valid to upgrade.