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AhsayOBM/ACB 7.9.0.0 shows [UnsatisfiedLinkError] after upgrade

June 3, 2025

Product Version

AhsayCBS: 7.5.0.0 to 7.x

Operating System

All Platforms

Symptom

After upgrading AhsayOBM / ACB from version 6.27.0.0 to 7.9.0.0 on Windows, the following error message is received in the backup reports of all subsequent manual and scheduled backup:

No.TypeTimestampLog
*.........
*info...Start creating Shadow Copy Set...
*erroYYYY/MM/DD hh:mm:ss[UnsatisfiedLinkError] com.ahsay.obx.core.backup.file.ShadowCopy.getVolume
ShadowNameByOtherProvider (Ljava/util/ArrayList;ILcom/ahsay/afc/event/
BackupSetEvent;Ljava/lang/String;Z)J
*.........

Cause

This error can be caused by a customization / branding issue related to some of the .ico and or .icns files used for AhsayOBM / ACB (e.g. incorrect pixel dimensions).

As a result, the client application build process was not complete properly, and the following DLL files shwcpy2k332.dll, shwcpy2k364.dll, shwcpyxp32.dll and shwcpyxp64.dll for the client agents' installer were not properly updated.

Resolution

To resolve the issue, re-upload the correct AhsayOBM / ACB .ico and .icns files (example: desktop.ico, installer.ico, uninstall.ico, desktop.icns, installer.icns etc) with the correct pixel dimensions.

For details of the pixel dimensions, please refer to the following pages on the AhsayCBS web console:

  • Select System Settings, Basic, then select Administrative Access, system, Rebrand Clients, and Custom Files - OBM
  • Select System Settings, Basic, then select Administrative Access, system, Rebrand Clients, and Custom Files - OBC
  • Select System Settings, Basic, then select Administrative Access, system, Rebrand Clients, and Custom Files - ACB