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Exchange DAG backups not running due to invalid host setting

May 20, 2025

Product Version

AhsayOBM: 7.3.2.0 - 7.5.0.2

Operating System

Windows

Symptom

Scheduled and continuous backup jobs of MS Exchange DAG server backup set are not running.

Further checking on the "Run scheduled backup on computers named" setting of the corresponding backup set, ? is displayed as host name of the cluster members:

exchange-dag-backup-not-running-invalid-host-setting-01.png

To check on the "Run scheduled backup on computers named" setting, login to the AhsayCBS console

Backup / Restore > Users, Groups & Policies > Backup User > Corresponding User > Backup Set > Corresponding Backup Set > Backup Schedule / Continuous Backup

Cause

Computer name of the DAG members cannot be correctly configured, this is a known issue with AhsayOBM 7.3.2.0 - 7.5.0.2.

Resolution

To resolve the issue, patch the AhsayOBM application on all affected DAG member servers to version 7.7.0.0 or above.

Re-enable the backup schedule on each DAG member servers afterward:

In the AhsayOBM user interface, select Backup Sets > Corresponding Backup Set > Backup Schedule \ Continuous Backup

exchange-dag-backup-not-running-invalid-host-setting-02.png