Hyper-V Cluster backups not running due to invalid host setting
Product Version
Operating System
Symptom
Scheduled and continuous backup jobs of Hyper-V Cluster VM backup set are not running.
Further checking on the "Run scheduled backup on computers named" setting of the corresponding backup set, ? is displayed as host name of the cluster members:
To check on the "Run scheduled backup on computers named" setting, login to the AhsayCBS console
Backup / Restore > Users, Groups & Policies > Backup User > Corresponding User > Backup Set > Corresponding Backup Set > Backup Schedule / Continuous Backup
Cause
Computer name of the cluster members cannot be correctly configured, this is a known issue with AhsayOBM 7.3.2.0 - 7.5.0.2.
Resolution
To resolve the issue, patch the AhsayOBM application on all affected Hyper-V cluster member servers to version 7.7.0.0 or above.
This issue affects a legacy version of our software. We strongly recommend upgrading to the latest AhsayCBS and AhsayOBM release (v9.15.0.0, as of 2025/May/15) for improved performance, compatibility, and security.
Contact us to confirm your license is valid to upgrade.
Re-enable the backup schedule on each Hyper-V cluster member servers afterward:
In the AhsayOBM user interface, select Backup Sets > Corresponding Backup Set > Backup Schedule \ Continuous Backup