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Cannot upload custom .ico files for client branding in AhsayCBS

June 2, 2025

Product Version

AhsayCBS: 7.5.0.0

Operating System

All Platforms

Symptom

When customizing the backup clients installer via the AhsayCBS web console at [Basic] > [Administrative Access] > [System Account] > [Rebrand Clients], custom .ico icon file cannot be uploaded. The page refresh to the [Administrative Access] page, but the icon file was not uploaded.

Further checking on the CBS context log (e.g. cbs_context_YYYY-MM-SS.log) on the AhsayCBS server, the following error message is displayed:

Date h:mm:ss org.apache.catalina.core.ApplicationContext log
SEVERE:
java.lang.NullPointerException
at com.ahsay.cbs.system.config.accounts.EditSysUser$5.b(Unknown Source)
at com.ahsay.cbs.system.config.accounts.EditSysUser$5.a(Unknown Source)
at com.ahsay.cbs.system.config.accounts.EditSysUser$5.a(Unknown Source)
at com.ahsay.cbs.system.config.accounts.EditSysUser$5.a(Unknown Source)
at com.ahsay.cbs.system.config.accounts.EditSysUser$5.a(Unknown Source)
at com.ahsay.cbs.system.config.accounts.EditSysUser$5.execute(Unknown Source)

Cause

This is a known issue with AhsayCBS version 7.5.0.0.

Resolution

To resolve the issue, patch the AhsayCBS application to version 7.7.0.0 or above.

This issue affects a legacy version of our software. We strongly recommend upgrading to the latest AhsayCBS and AhsayOBM release (v9.15.0.0, as of 2025/May/15) for improved performance, compatibility, and security.

Contact us to confirm your license is valid to upgrade.