UpdateFilter.do returns incorrect "Filter name in use" error
May 21, 2025
Product Version
AhsayCBS: Pre-7.7.0.0
Operating System
All Platforms
Symptom
Incorrect error message is returned when calling the UpdateFilter.do API to update settings of an existing backup filter.
"Filter name is already in use" is always returned with status error, which is incorrect. For example:
API call: UpdateFilter.do
JSON Post:
{
"SysUser":"system",
"SysPwd":"system",
"LoginName":"username",
"BackupSetID":"backupset_id",
"Name":"filter_name",
"ID":"filter_id",
"TopDir":"C:\\directory",
"Type":"DEFAULT",
"Include":false,
"Only":true,
"Apply2Dir":true,
"Apply2File":true,
"Patterns":[{"Pattern":".txt"},{"Pattern":".png"}]
}
JSON Return:
{
"Status":"Error",
"Message":"Filter name is already in use.",
"ExptType":"com.ahsay.obs.core.dbs.e"
}
Cause
This is a known issue with AhsayCBS version 7.5.0.0 - 7.5.0.6.
Even with the error message displayed, the backup filter is actually updated correctly by the UpdateFilter.do API call.
Resolution
To resolve the issue, patch the AhsayCBS application to version 7.7.0.0 or above.
This issue affects a legacy version of our software. We strongly recommend upgrading to the latest AhsayCBS and AhsayOBM release (v9.15.0.0, as of 2025/May/15) for improved performance, compatibility, and security.
Contact us to confirm your license is valid to upgrade.