AhsayACB continuous backup doesn't clear network session after ended
May 30, 2025
Product Version
AhsayACB / AhsayOBM: 7.3.2.0 - 7.5.0.0
Operating System
Windows
Symptom
For backup set with the temporary directory set to a network volume, the network share session is not cleared after a continuous backup job is completed:
[IMAGE-1]
Rhis build up of network share session will eventually cause sub-sequence backups to fail with the following error in the Backup Job Logs (YYYY-MM-DD-hh-mm-ss.log) :
[YYYY/MM/DD hh:mm:ss] [info] [backupset_id] NetUse Login:domain\administrator Password:??? Path:\\network\share Error: No more connections can be made to this remote computer at this time because there are already as many connections as the computer can accept.
[YYYY/MM/DD hh:mm:ss] [erro] [backupset_id] Failed to access "\\network\share" in destination "Destination Name".
This issue will only affect jobs performed with the Continuous Backup option.
Cause
This is a known issue with AhsayOBM / ACB version 7.3.2.0 - 7.5.0.0.
Resolution
To resolve the issue, patch the AhsayCBS application to version 7.7.0.0 or above.
This issue affects a legacy version of our software. We strongly recommend upgrading to the latest AhsayCBS and AhsayOBM release (v9.15.0.0, as of 2025/May/15) for improved performance, compatibility, and security.
Contact us to confirm your license is valid to upgrade.