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"Access Is Denied" error during Granular Restore

June 4, 2025

Product Version

AhsayOBM: 7.13.0.0 to 7.17.x

Operating System

Windows

Symptom

When performing a granular restore of selected files/folders from Hyper-V or VMware ESXi/vCenter guest VM. The following error message is shown in the AhsayOBM restore log when trying to restore files from the mounted virtual disk "Access is denied" .

No.TypeTimestampLog
*.........
*info......
*erroYYYY/MM/DD hh:mm:ssCannot copy "Windows10.vmdk (Volume-1)\Photos\group_photo_01.jpg", Reason = "\\.\vstor2-mntapi20......\Photos\group_photo_01.jpg (Access is denied)" 
*.........

Also, when trying to copy the files directly from the mapped virtual disk using Windows File Explorer, a "File Access Denied" error is returned by Windows.

granular-restore-access-denied-encrypted-files-01.png

Cause

The selected files/folders on the mounted virtual disk are encrypted. For example, if the "Encrypt contents to secure data" option is select in Advanced Attributes.

granular-restore-access-denied-encrypted-files-02.png

Resolution

To resolve this problem, we recommend you either:

  1. Use RunDirect to power on the guest VM, and login using the authorized credentials to access the files/folders on the drive.
  2. Restore the guest VM to VMware or Hyper-V host and power on the guest, and login using the authorized credentials to access the files/folders on the drive.