Invalid ID error during Office 365 Exchange Online mailbox backup
May 28, 2025
Product Version
AhsayOBM: 7.9.0.0 - 7.15.2.2
Operating System
Windows, Mac OS X
Symptom
When performing a Office365 Exchange online backup for mailbox of large number of mail items, the following error message is received in the backup report:
No. | Type | Timestamp | Log |
* | ... | ... | ... |
* | info | ... | Start running post-commands |
* | ... | ... | [List] 100% (xxxx/xxxx) Listing items from: ... |
* | erro | YYYY/MM/DD hh:mm:ss | [Bptree.KeyRangeIterator.hasNext] Error=[ExchangeStandardFolder.getOrdinal] Invalid ID: 14tknLeaf=[TreeKeyNode.toString]@xxxx lBlockStart='xxxx' lNextBlockOffset='xxxx' lFirstBlockOffset='xxxx' 1LastBlockOffset='xxxx' bIsLeaf='true' lRightSiblingOffset='xxxx' sslKeys=',[TreeNode.KeyMap@xxxx] sKey='[IBptree.SimpleKey] Key='xxxx''lLeftRefBlockNo='xxxx',[TreeNode.KeyMap@xxxx]sKey='[IBptree.SimpleKey] Key='xxxx''lLeftRefBlockNo='xxxx',[TreeNode.KeyMap@xxxx] ... (truncated) |
* | ... | ... | ... |
The error message above has been truncated, confirm if your backup has similar issue by searching for keywords "ExchangeStandardFolder.getOrdinal" in the backup report.
Cause
This is a known issue with AhsayOBM version 7.9.0.0 - 7.15.2.2.
Resolution
To resolve the issue, patch the AhsayOBM application to version 7.17.0.0 or above.
This issue affects a legacy version of our software. We strongly recommend upgrading to the latest AhsayCBS and AhsayOBM release (v9.15.0.0, as of 2025/May/15) for improved performance, compatibility, and security.
Contact us to confirm your license is valid to upgrade.