Hyper-V Granular Restore error "Failed to list file"
May 15, 2025
Product Version
AhsayOBM / AhsayOBR: 7.13.0.0 to 7.17.x
Operating System
Windows
Symptom
When performing a granular restore of a Hyper-V guest VM the following error message is shown by AhsayOBM when trying to mount the virtual disk "Failed to list file (The volume does not contain a recognized file system. Please make sure that all required file system drivers are loaded and that the volume is not corrupted)".
When browsing the virtual disk in AhsayOBM the contents is empty.
Cause
The drive(s) of the Windows guest VM is encrypted with security software, i.e. BitLocker or other third party security software
Resolution
To resolve this problem we recommend you either:
- Use RunDirect to power on the guest VM, unlock the drive using the security software to access the files/folders on the drive.
- Restore the guest VM to Hyper-V host and power on the guest, unlock the drive using the security software to access the files/folders on the drive.