Deleted Outlook mails re-backed up from Deleted Items in AhsayOBM
Product Version
Operating System
Symptom
When performing an Office 365 Online Exchange backup for a mailbox with email deleted since last backup, AhsayCBS / OBM / ACB misinterpret the action as deleted mail (delete from original folder), then backup the same mail again (as new mail from Deleted Items folder).
The following informative messages are displayed in the backup client log:
[YYYY/MM/DD hh:mm:ss] [info] [backupset_id] Total New Directories = 0
[YYYY/MM/DD hh:mm:ss] [info] [backupset_id] Total New Mails = 1
[YYYY/MM/DD hh:mm:ss] [info] [backupset_id] Total Updated Mails = 0
[YYYY/MM/DD hh:mm:ss] [info] [backupset_id] Total Properties Updated Mail = 0
[YYYY/MM/DD hh:mm:ss] [info] [backupset_id] Total Deleted Directories = 0
[YYYY/MM/DD hh:mm:ss] [info] [backupset_id] Total Deleted Mails = 1
I am so note...This issue will only affect deleted email (e.g. move from Inbox to Deleted Items folder). AhsayCBS / OBM / ACB can correctly detect other movement in mailbox to be backup (e.g. move from Inbox 1 to Inbox 2).
Since version 7.15.0.8, Ahsay software are enhanced to support move file for Office 365 Exchange Online backup set.
For example, if a user deletes a mail from the Inbox folder on the Office 365 Outlook user interface, AhsayCBS / OBM / ACB will not backup the same mail again. The mail should be treat as a moved file from Inbox to Deleted Items (e.g. changing the folder reference, instead of backing up the same mail again).
Cause
<p>vThis is a known issue with AhsayCBS / OBM / ACB version 7.15.0.8 - 7.15.0.20.</p>
Resolution
To resolve the issue, patch the AhsayCBS / OBM / ACB client application to version 7.17.2.2 or above.
This issue affects a legacy version of our software. We strongly recommend upgrading to the latest AhsayCBS and AhsayOBM release (v9.15.0.0, as of 2025/May/15) for improved performance, compatibility, and security.
Contact us to confirm your license is valid to upgrade.