AhsayACB cannot run Data Integrity Check or Space Freeing Up job
June 2, 2025
Product Version
AhsayACB / AhsayOBM: Pre-7.15.4.10
Operating System
All Platforms
Symptom
When performing a Data Integrity Check or a Space Freeing Up job on the backup client interface, the job completed with error:
Clicking on View log will show the following error messages:
For a data integrity check
"Please run integrity check later for destination \"destination_id\". Error: \"[d] Failed to initialize RemoteBDB.Cloud. Error=null, caused by [NullPointerException] null\""
OR
For a space freeing up job
"Failed to run space free up of destination \"destination (destination_id)\". Error: \"[bW] [AbstractLogFile.ParseExpt] [AbstractLogFile.read] Line x of 'directory_path\\.obm\\statistics\\Usage\\YYYY-MM-DD.log' is corrupted. Error=null, caused by [NullPointerException] null\""
Cause
The error message suggests that one of the backup client statistic log is corrupted.
Resolution
To resolve the issue, patch the AhsayOBM / ACB application to version 7.15.4.10 or above.
This issue affects a legacy version of our software. We strongly recommend upgrading to the latest AhsayCBS and AhsayOBM release (v9.15.0.0, as of 2025/May/15) for improved performance, compatibility, and security.
Contact us to confirm your license is valid to upgrade.