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AhsayOBM Dropbox CloudFile Backup fails: newFolderIterator error

May 30, 2025

Product Version

AhsayCBS / AhsayACB / AhsayOBM: 7.9.0.0 - 7.15.2.2

Operating System

All Platforms

Symptom

When performing a CloudFile backup for data on Dropbox, the following error message is received in the backup report:

No.TypeTimestampLog
*.........
*info...Start running post-commands
*.........
*......Using Temporary Directory temp_path\backupset_id\...
*erroYYYY/MM/DD hh:mm:ss[BackupCloudFileCmd.uploadBackupFiles][com.ahsay.afc.cloud.d] Error=[d] 
DropboxManager.newFolderIterator: , caused by [ServerException] 
*.........

Or

*erroYYYY/MM/DD hh:mm:ss[BackupCloudFileCmd.uploadBackupFiles][com.ahsay.afc.cloud.d] Error=[d]
DropboxManager.newFolderIterator: unexpected HTTP status code: 502:
{"error": "Internal Server Error"}n, caused by [BadResponseCodeException]
unexpected HTTP status code: 502: {"error": "Internal Server Error"}n 
*.........

Cause

Exceptions returned from Dropbox was not handled properly, this is a known issue with AhsayCBS / AhsayACB / AhsayOBM version 7.9.0.0 - 7.15.2.2.

Resolution

To resolve the issue, patch the AhsayCBS / AhsayACB / AhsayOBM application to version 7.17.2.2 or above.

This issue affects a legacy version of our software. We strongly recommend upgrading to the latest AhsayCBS and AhsayOBM release (v9.15.0.0, as of 2025/May/15) for improved performance, compatibility, and security.

Contact us to confirm your license is valid to upgrade.