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Error 577: Windows can't verify driver during Hyper-V Run Direct

May 16, 2025

Product Version

AhsayOBM: 7.9.0.0 to 7.17.x

Operating System

Windows

Symptom

When performing a Hyper-V VM Run Direct restore, the following error is displayed on AhsayOBM client interface:

Failed to open driver: Error = System error 577 has occurred. Windows cannot verify the digital signature for this file. A recent hardware or software change might have installed a file that is signed incorrectly or damaged, or that might be malicious software from an unknown source.”

hyperv-rundirect-restore-error-577-01.png

This issue will not occur when performing non-Run Direct restore for the affected Hyper-V backup set.

Cause

This issue can occur if the driver file FSRedirector.sys (found in the AhsayOBM installation folder) for Run Direct restoration was not sign with a digital signature during the Ahsay customization and branding process.

Resolution

To resolve the issue, digitally sign the AhsayOBM installer.

  1. Login to AhsayCBS web console.
  2. Select System Settings > Basic > Administrative Access > System > Rebranded Clients > Digital Signature. Enable the Digital Signature feature

    hyperv-rundirect-restore-error-577-02.png

  3. Under Digital certificate used to sign all EXE/JAR files, select:

    Use Ahsay Systems Corporation Certificate if you do not have a digital certificate

    OR

    Use certificate in mycredentials.spc/mycert.pfx uploaded if you have your own digital certificate

  4. Save, and build the client installer again afterward.
  5. After the build is completed, download and re-install the digitally signed AhsayOBM installer on the Hyper-V server.

    To verify the Digital Signature on the new AhsayOBM installation. On the Hyper-V server:

    • Browse to the AhsayOBM installation bin folder at ${OBM_Install_Home}\bin
    • Right-click on the FSRedirector.sys file, then select Properties.
    • Select the Digital Signatures tab to verify the digital signature is present.

      hyperv-rundirect-restore-error-577-03.png