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AhsayOBM backup fails with "Error=[ABlock.parse] Cannot parse file"

June 3, 2025

Product Version

AhsayACB / AhsayOBM: 7.3.0.0- 7.x

Operating System

All Platforms

Symptom

When performing a backup of any type, the following error message is received in the backup report:

The error message above has been abbreviated, confirm if your backup has similar issue by searching for keywords "Cannot parse file" in the backup report.

Cause

The message suggests that there is an issue with the index file.

Resolution

To resolve the issue, rebuild the index files of the affected backup set:

  1. Patch the AhsayOBM / ACB application to version 7.15.6.38 or above.
  2. Login to the AhsayOBM / ACB user interface.
  3. Select Utilities, then Data Integrity Check

    backup-fails-with-cannot-parse-file-error-01.png

  4. Select the affected backup set and the corresponding backup destination from the drop down menus.
  5. Ensure that the Rebuild index option is enabled

    backup-fails-with-cannot-parse-file-error-02.png

    Also enable the Run Cyclic Redundancy Check (CRC) option if you want to also check on the integrity of the backup data.
  6. Click Start to start the index rebuild process.
  7. Perform another backup after the rebuild is completed to confirm if the problem is resolved.