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VMWare Restore error "Failed to restore "New Virtual Machine"

May 15, 2025

Product Version

AhsayOBM: 7.5.0.0 to 7.17.x

Operating System

All Platforms

Symptom

When performing a restore (Run Direct or traditional restore) to another VMware ESXi host the following error message is shown:

No.TypeTimestampLog
*.........
*erroYYYY/MM/DD hh:mm:ssFailed to restore "New Virtual Machine". Reason = "Fail to set entity permission. Error=Unknown error from class "com.vmware.vim25.UserNotFound"
*info......

Cause

This is a known issue on AhsayOBM when restoring a guest VM to an alternate location or standby VMware host.

This issue occurs if the VMware user account assigned to the guest VM on the original VMware host does not exist on the standby VMware host.

Resolution

To workaround this issue:

  1. Login to the standby VMware host using vSphere using root credentials.

    vmware-failed-to-restore-new-virtual-machine-to-alternate-esxi-host-01.png

  2. Check the vSphere [Recent Task] list to identify which user accounts is missing on the VMware host.

    vmware-failed-to-restore-new-virtual-machine-to-alternate-esxi-host-02.png

  3. Go to [Inventory]>[Users] tab.

    vmware-failed-to-restore-new-virtual-machine-to-alternate-esxi-host-03.png

  4. Right click and [Add] the missing user account.

    vmware-failed-to-restore-new-virtual-machine-to-alternate-esxi-host-04.png

  5. After adding the new account, run the restore again.