Index migration runs on every job after Exchange DAG backupset upgrade
May 21, 2025
Product Version
AhsayOBM: 7.3.2.0 - 7.5.0.2
Operating System
Windows
Symptom
For MS Exchange DAG mail level backup set created by AhsayOBM version 6, after upgrading the client application to version 7.3.2.0 - 7.5.0.2, index migration is performed on every backup jobs.
The following informative messages are received in the Backup Job Logs during index migration:
[YYYY/MM/DD hh:mm:ss] [info] [100] Migrating index entry Job="Current" Path="Microsoft Exchange" Type="T" from v6 to v7
[YYYY/MM/DD hh:mm:ss] [cbs] [100] info,"Migrating index entry Job=\"Current\" Path=\"Microsoft Exchange\" Type=\"T\" from v6 to v7",0,0,0,,
...
[YYYY/MM/DD hh:mm:ss] [info] [100] Saving encrypted backup file index to backupset_id/blocks at destination CBS...
[YYYY/MM/DD hh:mm:ss] [info] [100] Saving encrypted backup file index to backupset_id/blocks/YYYY-MM-DD-hh-mm-ss at destination CBS...
...
[YYYY/MM/DD hh:mm:ss] [info] [100] Marking this v6 destination as index migrated to server ...
[YYYY/MM/DD hh:mm:ss] [cbs] [100] info,Marking this v6 destination as index migrated to server ...,0,0,0,,
Index migration should only be performed once by the initial backup job performed after the upgrade (except if the initial backup job failed).
Cause
This is a known issue with AhsayOBM 7.3.2.0 - 7.5.0.2.
Resolution
To resolve the issue, patch the AhsayOBM application on all affected Exchange DAG members to version 7.7.0.0 or above.
This issue affects a legacy version of our software. We strongly recommend upgrading to the latest AhsayCBS and AhsayOBM release (v9.15.0.0, as of 2025/May/15) for improved performance, compatibility, and security.
Contact us to confirm your license is valid to upgrade.