Cannot run Linux CLI backup for Backupset created via AhsayCBS
Product Version
Operating System
Symptom
For backup set created via the AhsayCBS web console, when attempting to start a backup of any type on Linux CLI (command-line interface), the following error message is received, even when there is no backup job of the same backup set running:
Using APP_HOME : /usr/local/obm
Using SETTING_HOME :
...
Running Backup Set - 'backupset name' ...
log4j:WARN No appenders could be found for logger (org.apache.http.impl.conn.Poo lingClientConnectionManager).
log4j:WARN Please initialize the log4j system properly.
log4j:WARN See http://logging.apache.org/log4j/1.2/faq.html#noconfig for more in fo.
[YYYY/MM/DD hh:mm:ss] start,"Start [ Linux platforms (hostname), AhsayOBM v7.5.0.0 ]",0,0,0,,
[YYYY/MM/DD hh:mm:ss] sIpcContent == NULL
[YYYY/MM/DD hh:mm:ss] Another backup job is still running. Backup skipped.
[YYYY/MM/DD hh:mm:ss] end,BS_STILL_RUNNING,0,0,0,,
Cause
This is a known issue with AhsayOBM 7.3.2.0 - 7.5.0.0, the encryption setting of a backup set is incorrectly configured.
Resolution
To resolve the issue, for Linux with GUI, login to the AhsayOBM user interface to re-configure the encryption setting of the affected backup set.
For Linux without GUI, patch the AhsayOBM application to version 7.7.0.0 or above.
Execute the RunConfigurator.sh script in the AhsayOBM installation bin directory afterward, to configure the encryption setting for the affected backup set.
This issue affects a legacy version of our software. We strongly recommend upgrading to the latest AhsayCBS and AhsayOBM release (v9.15.0.0, as of 2025/May/15) for improved performance, compatibility, and security.
Contact us to confirm your license is valid to upgrade.