Microsoft 365 Backup on AhsayCBS Fails with MFA Error
Product Version
Operating System
Symptom
When running Microsoft 365 Backup, the following error (or similar error) is found in the backup log/report:
Multi-Factor Authentication is enabled for this Microsoft 365 account and this backup set has not been authorized yet. Please authorize it by updating the backup set settings.
Cause
Microsoft has announced mandatory multi-factor authentication (MFA) enforced in phases, with broader enforcement beginning October 1, 2025
Microsoft’s announcement: https://learn.microsoft.com/en-us/entra/identity/authentication/concept-mandatory-multifactor-authentication?tabs=dotnet#enforcement-phases
During this transition, the error might occur in Microsoft 365 Backup.
Resolution
Ahsay released the following unofficial hotfix for AhsayCBS v10.1.0 to tackle this issue. Please apply it to AhsayCBS and enable Auto-update for the corresponding backup users to resolve: (This fix will be bundled in AhsayCBS v10.1.2 Official release)
The fix is based on v10.1.0. Please upgrade your CBS first if you are on a lower version.
AhsayCBS Hotfix Installation Guide: https://www.ahsay.com/en/support/help-centre/how-to/cbs/gen/cbs-hotfix-installation-guide
- All hotfix packages are cumulative, the latest one will include all the fixes in the previous ones.
- Conduct basic testing before rolling out hotfixes to production systems.
- Deploy hotfixes to only the affected production systems. (For CBS AUA Hotfix, disabling AUA for each user before updating would be a good practice.)
Only licenses covered by valid maintenance are eligible for upgrades. If your maintenance has expired, you are not entitled to upgrade to newer releases. Installing and running an AhsayCBS version released after your maintenance expiry date will cause the backup server to stop functioning. For assistance, please contact Ahsay Sales.