Microsoft 365 Backup on AhsayCBS Fails with MFA Error
Product Version
Operating System
Symptom
When running Microsoft 365 Backup, the following error (or similar error) is found in the backup log/report:
Multi-Factor Authentication is enabled for this Microsoft 365 account and this backup set has not been authorized yet. Please authorize it by updating the backup set settings.
Cause
Microsoft has announced mandatory multi-factor authentication (MFA) enforced in phases, with broader enforcement beginning October 1, 2025
Microsoft’s announcement: https://learn.microsoft.com/en-us/entra/identity/authentication/concept-mandatory-multifactor-authentication?tabs=dotnet#enforcement-phases
During this transition, the error might occur in Microsoft 365 Backup.
Resolution
Ahsay released v10.1.2, the official release, to tackle this issue. Please update your Backup server and enable Auto-update for the corresponding backup users to resolve:
How to Install Latest AhsayCBS Release
Only licenses covered by valid maintenance are eligible for upgrades. If your maintenance has expired, you are not entitled to upgrade to newer releases. Installing and running an AhsayCBS version released after your maintenance expiry date will cause the backup server to stop functioning. For assistance, please contact Ahsay Sales.