Skip to main content

Backup skipped due to invalid backup job ID detected

December 4, 2025

Product Version

AhsayOBM / AhsayACB: 7 and above

Operating System

All platforms

Symptom

Backup was skipped and the following message is received in the backup report:

[FileService.checkBackupJobID] Invalid backup job ID '2025-10-27-20-40-49' which is before the previous backup job ID '2026-10-26-14-01-00' for user 'BackupUser', backup set 'File (1755703865531)'

Cause

This error occurs when the system date and time in the client machine is set ahead of the actual current time. As a result, the last backup was recorded with a future timestamp. When a new backup runs, it detects this backup with a future timestamp and in turn skips the process to avoid data inconsistency.

Resolution

To resolve the issue, follow the steps below:

  1. Delete the backup snapshot with the future timestamp from the backup destination.

    If you need assistance, please contact the Support Team and provide a screenshot showing the latest snapshot folder date inside the blocks folder as well as the AhsayCBS read-only admin access.
  2. Verify that the system date and time are correct in the AhsayOBM client machine. Ensure that system time synchronization (e.g. via NTP) is enabled to prevent recurrence of this issue.
  3. Stop the AhsayOBM/AhsayACB service and make sure no backup process is currently running.
  4. Move all files located under %temporary_directory%/index to another location.
  5. Restart the AhsayOBM/AhsayACB service and wait for the next scheduled backup to run.