We would like to inform you that our previous patches v9.15.2.59 and v10.3.4.0 did not fully address the following security vulnerabilities:
CVE-2026-105133
CVE-2026-105134
Given the severity of these risks, we strongly urge you to take immediate action to secure your environment and protect your customers data.
After applying the hotfix, please reboot your server.
We would like to inform you that our previous patch v10.3.4.0 did not fully address the following security vulnerabilities:
CVE-2026-105133
CVE-2026-105134
Given the severity of these risks, we strongly urge you to take immediate action to secure your environment and protect your customers data.
Partners running affected v10 versions should apply the AhsayCBS v10.3.4.45 hotfix, available at: https://www.ahsay.com/en/hotfix-v10-partner-only (A valid partner portal login account is required)
After applying the hotfix, please reboot your server.
We have recently received inquiries from various sources regarding the following two vulnerabilities, both of which were addressed in AhsayCBS v10.3.4.0, released on 4 August 2026:
https://vuldb.com/cve/CVE-2026-105133
https://vuldb.com/cve/CVE-2026-105134
We would like to clarify that partners who have already upgraded to v10.3.4.0 are no longer affected by these vulnerabilities and are protected against remote exploitation by unauthenticated attackers.
However, if your backup server was compromised prior to upgrading to v10.3.4.0, the upgrade itself would not resolve any issues arising from the compromise. In such cases, we strongly recommend engaging qualified cybersecurity professionals to conduct a thorough investigation and perform any necessary remediation activities.
We are pleased to announce the official release of Ahsay v10.3.4 which now supports:
Click here to view the full release notes.
We are pleased to announce the official release of Ahsay v10.3.2 which now supports:
Click here to view the full release notes.