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Note

If you are branding this document for your customers, please be reminded to:
1. Modify the “header” and “footer” of this document
2. Change all references of www.ahsay.com to your server
3. Take away those sections that are not relevant to your customers, e.g. the
section on “Branding”
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1. General

1.1 Can you briefly explain the idea of how the Ahsay Online Backup
Software works?

The Ahsay Online Backup Suite consists of 3 main modules:

1. The client software — Ahsay Online Backup Manager (AhsayOBM) and A-Click
Backup Client (AhsayACB)

2. The server software — Ahsay Offsite Backup Server (AhsayOBS)
3. The replication server — Ahsay Replication Server (AhsayRPS)

AhsayOBM is a client application with a user-interface for easy backup configuration. It
allows users to upload selected files to the Backup server and runs scheduled backup jobs. It
also allows users to create different backup sets for different backup purpose. Besides file
backup, AhsayOBM can backup a list of applications such as MS Exchange, MS SQL, Oracle,
MySQL, Lotus Domino, and much more. AhsayOBM supports Windows 2000, XP, 2003, Vista,
Linux, Mac OS X, etc.

AhsayACB is a client application with essential file backup functionalities and an intuitive
user-interface targeting for simple end-users. It allows users to upload selected files to the
Backup server and runs scheduled backup jobs.

AhsayOBS is a server application which store backup data from multiple AhsayOBMs backup
accounts. It has a web-based Management Console for system administrators to manage the
Backup Server, such as configuring system and backup account settings, and viewing backup
statistics and reports. Users can also logon to this Management Console to manage their own
backup account or restore their own backup data. AhsayOBS supports Windows, Linux and
Mac OS platforms.

AhsayRPS is another server application running on a separate machine, it provides close to
real-time backup for multiple AhsayOBSs. So even if one of the AhsayOBS failed, the RPS still
has a copy of the backup data.

The relationships of the Ahsay Online Backup Suite are depicted in the diagram below.

Q Linux@
Mac 05.1@ .
AR
Mys0 “@
[ ] p"‘}
%&?ﬁ@m@ “Sg

- @ Australia ®

QS Supported
Windows, Linux, Mac OS X, Novell NetWare, and Sun Solans

Application Supported

Micrasoft SQL Server, Micrasoft Exchange Server, Oracle Database, MySQL Database,
and Lotus Domino / Notes

~Back to top
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2. Branding (OEM Partners Only)

2.1. Can we remove the name Ahsay in the AhsayOBM software? Can
we put in our own company name/brand?

You can do your own branding for both AhsayOBS and AhsayOBM. This means that all Ahsay
reference can be changed to your company name and logo, so your client will not know this
is Ahsay Online Backup software.

~Back to top

2.2. Can | customize the desktop icon for AhsayOBM on the client
machine?

To customize the desktop icon, you will need to replace the iconl.ico file inside obm.zip, then
upload it to the Partners Portal and rebuild your customized installer.

If you want to change the desktop icon after the installation is done, you may try to right-click

the desktop icon, choose "Properties” and then click "Change Icon", then choose the one you
would like to change to.

~Back to top

2.3. How do | customize the company logo for AhsayOBM Mac OS OEM
version?

You can change the logo in the following path of the obm-mac archive:

(obm-mac.zip) >Setup.app > Contents > Resources > Setup.app > Contents > Resources >
Java > Diskl > InstData > (Resourcel.zip) > $IA_OBM_HOMES$ = BuildOBMv5.0 > platform
> obm-mac > BackupManager.app > (Contents_zg_ia_sf.jar) > Resources > OBMLogo.icns

~Back to top

3. Ahsay Online Backup Manager (AhsayOBM) / A-Click
Backup (ACB)

3.1. Can we customize the AhsayOBM? How can we change the name
of the software, configuration, and auto-logon?

Of course it is possible. You can refer to our Administrator's Guide as well as our Partner
Portal for more details.

~Back to top
3.2. What is the recommended bandwidth?

It really depends on what kind of data to be backed up, e.g. for personal file backups, the
daily data transfer should be limited, while MS Exchange backup could be significant. You
may want to use the following white paper as a reference:

http://www.ahsay.com/en/doc/white-paper-backup-speed.pdf.

~Back to top
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3.3. How do | run AhsayOBM with Microsoft ISA 2004?

To connect AhsayOBM to AhsayOBS through Microsoft ISA Server, please do the following to
enable [Web Proxy] service on the ISA Server:

1. Open [Start] -> [Programs] -> [Microsoft ISA Server] -> [ISA Server Management]

2. On the left panel, select [Microsoft Internet Security and Acceleration Server] ->
[SERVER] -> [Configuration] -> [Networks]
3. On the top menu, select [Action] -> [New] -> [Network]. Enter a “Network Name”

(e.g. Internal) and define the IP address range for your internal network
(e.g. 192.168.1.0 - 192.168.1.255)

4. Double click the new network that should now be added to on the bottom panel
Select the [Web Proxy] tab

6. Check both [Enable Web Proxy clients] and [Enable HTTP] checkboxes and choose a
[HTTP port] for the web proxy service

7. (Optional) Press the [Authentication] button, check the [Basic] checkbox and the
[Require all users to authenticate] checkboxes if you want to enable and enforce
proxy authentication

@

8. Press the [OK] button to make the changes and press the [Apply] button to apply the
changes

9. Open [Ahsay Online Backup Manager] from the system tray and press the [Options]
button

10. In the [Proxy Seting] section, select the [Proxy] radio button

11. Enter the hostname/IP address of the ISA server in the [Proxy Address] text field and
the TCP port for web proxy service on your ISA Server in the [Port] text field

12. Press the [OK] button to connect to the server

If you run into any problems connecting to the AhsayOBS from AhsayOBM using ISA Server,
please do the following to check if your request is being blocked:

1. On the left panel of [ISA Server Management], select [Microsoft Internet Security
and Acceleration Server] -> [SERVER] -> [Monitoring]

2. Then select the [Logging] tab that appears on the right panel3. Click the [Edit Filter]
link and create a filter with the following values:

» [Log Record Type] equals [Web Proxy Filter]
» [Destination IP] equals [The IP address of Ahsay Offsite Backup Server]
3. Press the [Start Query] button
4. Open [AhsayOnline Backup Manager] again and try connecting to the AhsayOBS

using the same procedure above.

Check if there are any errors generated in the log table.

~Back to top
3.4. How do I install AhsayOBM on FreeBSD?

You can either run AhsayOBM on a Linux version of Sun Java JDK (performance might not be
optimized) or on a FreeBSD native Java SDK.

Please do the following for the Linux version of Sun Java JDK option:

1. Install Linux binary compatible port to the FreeBSD machine

2. Install the Linux version of Sun Java 1.4.2 or above JDK onto the FreeBSD machine

3. Create a symbolic link from $OBM_HOME/jvm to $JAVA_HOME (installed in previous
step)

4. Run $OBM_HOME/bin/RunBackupSet.sh [BACKUP_SET_NAME] to run your backup
5. Run $OBM_HOME/bin/Scheduler.sh to start the backup scheduler

Please do the following for the FreeBSD native Java SDK option:
1. Install Linux binary compatible port to the FreeBSD machine
2. Install the Linux version of Sun Java 1.4.2 or above JDK onto the FreeBSD machine

3. Compile the FreeBSD native Java 1.4.2 SDK using the JDK compiler installed in the
previous step

Ahsay Systems Corporation Limited Page 7 of 48 (May 22, 2009)
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4. Install the FreeBSD native Java 1.4.2 SDK onto the FreeBSD machine
5. Create a symbolic link from $OBM_HOME/jvm to $JAVA_HOME (installed in previous
step)
6. Run $OBM_HOME/bin/RunBackupSet.sh [BACKUP_SET_NAME] to run your backup
7. Run $OBM_HOME/bin/Scheduler.sh to start the backup scheduler

~Back to top

How do I install AhsayOBM on SCO Unix?

Please do the followings to install OBM on SCO:

1.
2.
3.

4.

5.
6.

Install Java 1.4.x or above onto your SCO Unix box
Download obm-linux.tar.gz and expand it to $OBM_HOME (e.g. /usr/local/obm)

Delete $OBM_HOME/jvm and create a symbolic link from $OBM_HOME/jvm to the
SCO Unix Java VM

Run $OBM_HOME/bin/BackupManager.sh to setup your backup set (or run
$OBM_HOME/bin/Configurator.sh if you are under command line mode. Then use the
OBS Management Console to setup your backup sources and other settings)

Run $OBM_HOME/bin/RunBackupSet.sh [BACKUP_SET_NAME] to run your backup
Run $OBM_HOME/bin/Scheduler.sh to start the backup scheduler

~Back to top

How do | install AhsayOBM on AIX?

Please do the followings to install AhsayOBM on AlX:

1.
2.
3.

4.

5.
6.

Install Java 1.4.x or above (Java 1.4.2 or above recommended) onto your AlX box
Download obm-linux.tar.gz and expand it to $OBM_HOME (e.g. /usr/local/obm)

Delete $OBM_HOME/jvm and create a symbolic link from $OBM_HOME/jvm to the
AlX Java VM

Run $OBM_HOME/bin/BackupManager.sh to setup your backup set (or run
$OBM_HOME/bin/Configurator.sh if you are under command line mode. Then use the
web interface to setup your backup sources and other settings)

Run $OBM_HOME/bin/RunBackupSet.sh [BACKUP_SET_NAME] to run your backup
Run $OBM_HOME/bin/Scheduler.sh to start the backup scheduler

~Back to top

The Windows version of AhsayOBM installer hangs, what could be
the problem?

There are few things that could create errors during or after executing the installer.

1.
2.

3.

5.

Make sure there is enough disk space on the machine.
Make sure you do not have any anti virus software or PCanywhere running, as this
may create problems with InstallAnywhere installers.

There are also problems with InstallAnywhere installers and Dell OpenManager. If
OpenManager has installed on the target system, be sure to disable it before
installing AhsayOBM.

Hardware could cause errors as well, try set your [hardware acceleration display
setting] to off. There are problems with certain versions of Java running along with
certain video cards.

This may only be a Java problem.

Also, if you are transferring this file from one machine to another, please be sure the file size
is valid and you are transferring the file in binary mode.

Java Testing

Please try running any of the Swing demos that came with the Java runtime in 1.4.X and see
if it hangs on Windows. In order to fix this problem, some knowledge base on the Internet
suggested updating DirectX to at least DirectX 8.1. Most machines got this problem had
DirectX 7.0 installed. (You can use the “dxdiag” command to find out the directX version)
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SUN recommended two workarounds for certain video card issues

1. The following will pass properties to the installer's Virtual Machine:
In Advanced Designer — Project -> Config -> Additional Arguments
set that to "-Dsun.java2d.d3d=false -Dsun.java2d.noddraw=true" without the
quotes.

2. Set the following lax property in your LaunchAnywhere for your application's JVM:
lax.nl.java.option.additional=-Dsun.java2d.d3d=false -Dsun.java2d.noddraw=true

Add the same line to the uninstaller lax file, using a modify file action in your installer
in post-install.

~Back to top

3.8. The Installer doesn’t seem to work. How can | manually install
AhsayOBM on Windows?

To manually install AhsayOBM on Windows, you’ll need to copy and zipping the program
directory (e.g. C:\Program Files\AhsayOBM) from another machine with AhsayOBM installed.
Then do the followings on the machine you wish to manually install:

1. Create the directory C:\Program Files\AhsayOBM

2. Unzip the AhsayOBM program directory archive to C:\Program Files\AhsayOBM
3. Run C:\Program Files\AhsayOBM\bin\install.bat

4 Run C:\Program Files\AhsayOBM\bin\Install-Scheduler.bat

~Back to top

3.9. The Installer doesn’t seem to work. How can | manually install
AhsayOBM on Mac?

Try manually installing AhsayOBM on your Mac with the following instructions:
1. Download AhsayOBM from the http://www.ahsay.com.

2. Expand obc-mac.zip into /Applications/OBM
3. Run "chmod -R 755 /Applications/OBM" using Terminal
4 Double-click the “Ahsay Online Backup Manager” icon in /Applications/OBM folder

~Back to top
3.10. Error occurred when Installing AhsayOBM on Novell.

Some users would have problems when trying to install AhsayOBM on Novell Netware Client
version. (The machine had met all the system requirements: Netware v5.1 and Netware Java
v1.3.1). User could receive the following error message during installation.

Exception in thread "main”
Java.lang.noclass def found error.obm
Java: class obm exited with status 1

Check the following

Please check if the OBM_HOME environment variable set in
SYS:\OBM\bin\BackupManager.ncf is correct?

envset OBM_HOME=SYS:\OBM

envset OBM_CLASSPATH=$0BM_HOME\bin;$0OBM_HOME\bin\obm.jar;
$OBM_HOME\bin\obm-lib.jar

envset LIB_PATH=$0OBM_HOME\bin
java -mx384m -Djava.library.path=$LIB_PATH -cp $OBM_CLASSPATH obm SYS:\OBM

Please change the SYS:\OBM environment variable to your installation directory.

~Back to top
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3.11. Arethere any command line tools for AhsayOBM?

Yes, there are scripts in [OBM Program Home]\bin and they are described below:

Windows
° Decrypt.bat: decrypts the specified backup files

° install.bat: installs the AhsayOBM icon to the System Tray and registers the Ahsay
Online Backup Scheduler as a service

Install-Scheduler.bat: registers the Ahsay Online Backup Scheduler as a service
RegisterVSS.bat: re-registers Microsoft’s Volume Shadow Copy service DLLs
Remove-Scheduler.bat: un-registers the Ahsay Online Backup Scheduler service

Restore.bat: restores the specified snapshot of the backup set to the specified
location

RunBackupSet.bat: runs the specified backup set
RunOBM.bat: launches the Ahsay Online Backup Manager user interface

°

°

° Run-Scheduler.bat: starts the Ahsay Online Backup Scheduler service

° SeedLoad.bat: runs seed load for the specified backup set to the specified location
°

Uninstall.bat: removes the AhsayOBM icon from the System Tray and un-registers
the Ahsay Online Backup Scheduler service

L] BackupManager.sh: launches the Ahsay Online Backup Manager user interface

° Configurator.sh: configures client parameters such as Backup Server address,
username/password, encrypting key, etc.

Decrypt.sh: decrypts the specified backup files

Restore.sh: restores the specified snapshot of the backup set to the specified location
RunBackupSet.sh: runs the specified backup set

Scheduler.sh: starts the Ahsay Online Backup Scheduler service

SeedLoad.sh: runs seed load for the specified backup set to the specified location

StopScheduler.sh: stops the Ahsay Online Backup Scheduler service

*You may have to set some variables in these scripts and more instructions are provided.

~Back to top

3.12. How does AhsayOBM detect changes in files? Does it use the
Archive bit? Some tape backup software resets the Archive bit.
Would this affect AhsayOBM when backing up the same data?

AhsayOBM compares timestamps of files on the server with the corresponding copies on
client machine. Archive bit is not used as it does not detect relocated files. Therefore tape
backup would not affect AhsayOBM.

~Back to top
3.13. Does AhsayOBM copy the same set of files regularly?

After the initial upload, subsequent backup jobs will only transfer the modified or new data to
the Backup server. It depends on the nature of the data, but normally, less than 2% of all
data is modified.

~Back to top
3.14. Transfer Block Size is 128Kb by default. Is there a reason for this?

Backup data is transferred in blocks (instead of file by file) to minimize connection
negotiation roundtrips. It is not the TCP/IP block size. This setting is optimal for the backup
operation.

~Back to top
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3.15. How can | backup a huge data set over the Internet?

If you have a lot of data (e.g. 300GB) to backup to the Backup server, it would take a
considerable amount of time to perform the first full backup over the Internet. You can try the
following method:

1. Use the Seed Loading Utility to backup your backup set to a local hard disk (instead
of directly transfer to the Backup server)

2. Send the backup data, using a removable hard disk, to your backup service provider.

3. The administrator can then load all your backup files from your removable hard disk
into your backup account. This could save you days (even weeks) of performing your
first full backup.

In addition, subsequent backups are incremental (only new or updated files will be uploaded
to the server), the amount of data transfer should be relatively small.

Please refer to the User’s Guide for details on the “Seed Loading Utility”.

~Back to top
3.16. What is the best way to restore a huge data set?

You can copy the data of the particular backup set on AhsayOBS to a removable media, e.g.
external hard disk, and ship it to your client. Your client can then use the “Decypt Files Tool”
in AhsayOBM to restore the backup data from the removable media to its original format.

~Back to top
3.17. Does In-File Delta backup require a temporary working directory?

AhsayOBM requires a temporary storage for the delta file before it gets sent to the server.
For example:

If you have a 10GB file that has already been backed up to the server and you have
updated 10MB of this file. Then you need to have at least 10MB of free space in the
temporary directory for the delta file.
*Note: Certainly you do not need 10GB of free disk space.
Also, if you want to backup 5 x 10GB files in the same situation. You will only need 10MB of
free space (not 5 x 10MB), because each delta file will be automatically deleted right after it
has been backed up.

~Back to top
3.18. What is the average compression ratio?

All backup files are compressed and encrypted before uploading to the Backup Server, the
average compression ratio for text-based file is around 4:1. However, no further
compression can be made on files that are already in compressed format (e.g. JPG, ZIP). In
general, you can assume a 2:1 compression ratio when you are backing up a file set with
variety types.

~Back to top
3.19. Can I change my encrypting key?

The encrypting key cannot be changed once you setup your Backup Set. This is necessary for
the integrity of the Backup Set, making sure that backup data is only encrypted by one key.
Otherwise, you will have problems remember two encrypting keys when you want to restore
your files in the future.

You need to recreate your Backup Set if you really want to change your encrypting key.

~Back to top
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3.20.

3.21.

3.22.

3.23.

If the “Use Login Password as Encrypting Key” option was
selected when creating the backup set. Why | cannot restore the
backup data with my most current login password?

By selecting the “User Login Password as Encrypting Key” option when creating a backup set,
AhsayOBM will set your login password as the encrypting key for the backup set. Once set,
even if you change your login password afterward, the encrypting key will remain as your
original password. In other words, if you have changed your login password, you still need to
use the original password to decrypt and restore the backup set.

Currently, if the encrypting key is forgotten or lost, the backup set can never be restored. It
is not possible to restore without the key.

You can find out the encrypting key from the corresponding AhsayOBM, please refer to
http://download.ahsay.com/support/screenshots/EncryptingKey.jpg

~Back to top

What kind of encryption used by AhsayOBM?

There are two encryptions being performed by AhsayOBM:

1. Encryption of backup data - This is being done by 128-bit symmetric key
encryption (AES, TripleDES, TwoFish). 256-bit is not available because it requires too
much CPU and it is not really required. (128-bit is currently being used by most
banks)

2. Encryption of backup traffic - This is being done by 1024 bit RSA public key
encryption. The strength of the encryption depends on the key size you use when you
generate your CSR before submitting to your CA. 1024 bit is what is being used by
most CAs.

~Back to top

When select the backup option “local hard drive” to backup to
external hard drive, it fails in the middle of the process, why?

Please check if the external hard drive is in FAT32 volume format. And also check whether
there is any folder containing more than 32000 files and there is no file bigger than 4GB
within your backup set. It is a FAT32 limitation, you may try to convert the FAT32 volume to
NTFS.

~Back to top

Scheduled backup jobs are not running on my Windows machine,
why?

Please try the followings:

1. Check if [Control Panel] -> [Administrative Tools] -> [Services] -> [Online Backup
Scheduler] is available and started

2. Check if C:\Program Files\AhsayOBM\home.txt contains the home directory for your
backup account (e.g. C:\Documents and Settings\Administrator\.obm)

3. Check if C:\Program Files\AhsayOBM\jvm\bin\SchedulerOBM.exe exists

4. Check if C:\Program Files\AhsayOBM\log\Scheduler\info.log contains the startup
loading entry, e.g.

i [2005/12/12 12:42:44] OS Name=Windows XP

ii. [2005/12/12 12:42:44] OS Version=5.1

iii. [2005/12/12 12:42:44] Scheduler Version=5.0.1.3e

iv. [2005/12/12 12:42:44] Java Vendor=Sun Microsystems Inc. Version=1.4.2_10

V. [2005/12/12 12:42:44] [info] Starting Scheduler, User:'backup-account’,
Home:'C:\Documents and Settings\Administrator\.obm’
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5. Check if C:\Documents and Settings\Administrator\.obm\log\Scheduler\debug.log
contains the debugging information for your scheduler

If your system settings is not the same as the above steps, please download a new installer
(obc-win.exe) from our website or the customization portal and try again.

~Back to top
3.24. 1am having problems with my scheduled backup, why?

If you are backing up files from a network drive, please check if you have included the valid
“Network Resources Authentication” information for the backup set. This is required for
scheduled backups that access any network resources.

You can refer to the following screenshot:
http://download.ahsay.com/support/screenshots/Network_Resources_Authentication.JPG

~Back to top
3.25. | cannot get proxy authentication to work with AhsayOBM, why?

If you are using port 80, please check whether your proxy server accepts "HTTP CONNECT"
calls on port 80. You may also want to try other ports like 443 to see if your proxy server
accepts that.

~Back to top
3.26. Can | backup an entire Operating System?

Currently, it is not possible to do hard disk image backup with AhsayOBM. However, you can
still backup/restore the operating system by doing the followings:

To backup all files including the operating system, please do this:
1. Add all files to your backup source
2. Add a SystemState backup type to your backup account (Windows only)

To restore all files including the operating system, please do this:
1. Re-install the operating system and applications

2. Restore the SystemState backup to your machine (Windows only)
- To restore the System State data on a domain controller, you must first start your
computer in a special startup option called "Directory Services Restore Mode". To
access "Directory Services Restore Mode", press F8 during startup and select it from
the list of startup options.

3. Restore all files to your machine
~Back to top

3.27. When setting up a Microsoft SQL Backup Set, | cannot list the
available SQL servers, what can | do?

You can try running “osqgl —L” in a command prompt, you should see the following:
Servers:

(local)

SQLSERVERI\INSTANCE1

SQLSERVER2\INSTANCE2

If you have a firewall installed, please disable it. UDP Broadcast must be allowed.

~Back to top
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3.28. Why are the Microsoft SQL Server databases missing from the
backup source list?

If you have firewall installed on your network, please make sure UDP port 1434 is allowed on
the SQL Server.

~Back to top
3.29. How to set the recovery model of a MS SQL database to FULL?

You can change the recovery model by running the following commands, run it along with
each of the database that you want to run transaction log backup.

C:\> osql -E -S SQLSERVERI\INSTANCE1 -Q "ALTER DATABASE xxx SET RECOVERY FULL"
Where

SQLSERVERININSTANCEL = the SQL Server and the corresponding instance

xxx = the name of the database

~Back to top
3.30. Windows network map drive connections are not stable, why?
You may want to try editing a few Windows Parameters.

SMB Size

When running applications that copy or move a large amount of data to a remote server, the
speed of such action is determined by network speed and by the SMB (a protocal related to
Windows map drive) size.

NT/2000 negotiates the SMB size and will generally set this to 4K blocks for applications that
are moving or copying data to a remote server. By increasing this block size, you will allow
the server to complete its file copies faster. This will increase the performance of the
application making the copy/move calls.

HKEY_LOCAL_MACHINE\System\Current Control Set\Services\LanmanServer\Paramerters
"SizReqBuf"'= REG_DWORD

Set Value To: 16000 = HEXDEC
Ref: http://support.microsoft.com/default.aspx?scid=kb;en-us;320829

Map Drive Auto Disconnect Settings
Reference: http://support.microsoft.com/kb/138365/EN-US/
http://support.microsoft.com/default.aspx?scid=kb;en-us;297684

HKEY_LOCAL_MACHINE\System\Current Control Set\Services\LanmanServer\Paramerters

Autodisconnect to: fffffff

Creating BAT file for better performance

If you are still having problems, you may want setup a BAT file and scheduled this file to run
every 10 minutes, please setup the BAT file as follow:

BAT file settings:

ping mapdrv

ping 192.168.1.15

net config server /autodisconnect:-1

net use /persistent:yes

net use "\\mapdrv\DATA STORAGE1"

net use "\\192.168.1.15\DATA

net use d: \\192.168.1.15\DATA STORAGE1
net use e: "\\mapdrv\DATA STORAGE1"

dir d:\
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dir e:\
° mapdrv = your NAS device network name

° 192.168.1.15 = mapdrv

In addition, create a host file on the server hosting the program, have the following entry in
it:
L] mapdrv = 192.168.1.15

And if you are on a 2003 server, refer to the following:
Reference: http://support.microsoft.com/default.aspx?scid=kb;en-us;890553

For Windows 2000, you may want to install the following Hotfix:
Windows2000-KB903237-x86-ENU
Reference: http://support.microsoft.com/default.aspx?scid=kb;en-us;903237

~Back to top

3.31. Thereis an error when backing up files on aremote NetWare server,
what can | do?

If you want to backup \\SERVER\SHARE that is located on a NetWare server and you are
getting "Network drive is not accessible" error message. Please try adding the following
command as a [Pre-backup command]

net use \\SERVER\SHARE [PASSWORD] /USER:[DOMAIN | MACHINE_NAMEJ\[USERNAME]

This will authenticate the current process with the NetWare server and therefore allow your
backup to run correctly.

~Back to top

3.32. What are the advantages and disadvantages of backing up multiple
computers using a single backup account?

Advantages
° You require less backup accounts

L] You can use one username and password to configure the backup setting for all
Backup Sets

Disadvantages
° You must use different backup sets for different computers

° Whenever a new backup set is created under the backup account, you need to go
back to all computers using the same backup account to uncheck the “Run
scheduled backup on this computer” option for the new backup set (Since backup
setting is saved on server and new backup set is default to run on all computers, i.e.
with the option checked).

° Improper configuration could easily cause problems, which are difficult to debug.
~Back to top

3.33. How to find out which version of the client software the user is
using?

You can check which version a client is running by checking the access log.
The default location of the access log file is:

° Windows: “C:\Program Files\Ahsay Offsite Backup Server\logs\access_log*.txt”
° Linux: “/usr/local/obs/logs/access_log*.txt”
° Mac OS X: “/Applications/OBS/localhost/logs/access_log*.txt”

The ‘/obs/obcX. X/file/????File.obc?u=USER_NAME&..ver=Y.Y’ entries contain this
information, where:

L] USER_NAME = Login Name of a backup account
L] X.X = major version of the client software
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L] Y.Y = minor version of the client software

And starting from AhsayOBS v5.0.1.5, the version of OBM can be check from the AhsayOBS
Management Console under the [Manager User] -> [Report] -> [Detailed Report] page of the
corresponding user.

~Back to top

3.34. Does the AhsayOBM upgrade the installation of Java on a client
machine, or does it install a separate copy for its own use?

AhsayOBM uses its own copy of Java and leaves the system Java VM intact.

~Back to top

3.35. After upgrading AhsayOBS, do | have to upgrade all the AhsayOBM
as well? And do | need to transform/migrate their current data?

AhsayOBS works with previous versions of AhsayOBM (However not the other way round).
You only need to upgrade the existing client software if you want to take advantage of the
new features. And you do not need to transfer client backup data again after the AhsayOBS
ugprade.

~Back to top

3.36. Is it possible to do incremental or differential backups with
MySQL?

MySQL backup is done with SQL Dump file, and it generates a single file which is then
uploaded. These backup files usually very large size and it takes time to backup to the server.
At this moment, it is not possible to do incremental dump with mysqldump. But our In-File
Delta feature shall ensure that, instead of the entire backup file, only the changed data blocks
within the dump file are uploaded to the Backup Server.

~Back to top

3.37. How does the “Remove retention files for overlap policy” under
Advanced Retention Policy work?

In general, daily snapshots followed by a weekly snapshot or a monthly snapshot, etc. will be
removed; weekly snapshots followed by a monthly snapshot or a quarterly snapshot, etc. will
be removed; and so on.

This is illustrated by the following example.
Assume today is 17Jan06, and the Advanced Retention Policy is as follows:
o Daily: retain for 7 days
° Weekly: retain for 4 weeks (the job will be performed on Saturday)
° Monthly: retain for 3 months (the job will be performed on 1st of each month)
If “Remove retention files for overlap policy” is NOT enabled:
Then a total of 14 snapshots (7+4+3) will be kept on the server accordingly, i.e.:

(Daily): 10Jan06, 11Jan06, 12Jan06, 13Jan06, 14Jan06, 15Jan06, 16Jan06
(Weekly): 24Dec05, 31Dec05, 7Jan06, 14Jan06
(Monthly): 1Nov05, 1Dec05, 1Jan06

If “Remove retention files for overlap policy” is enabled:

Then only the following snapshots are kept: 1Nov05, 1Dec05, 1Jan06, 14Jan06, 15Jan06,
16Jan06.

Specifically, the weekly policy overrides the daily policy so 10Jan06, 11Jan06, 12Jan06 and
13Jan06 will be removed. The monthly policy overrides the weekly policy, and 24Dec05,
31Dec05 and 7Jan06 will be removed as well.

~Back to top
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3.38.  What is incremental backup and how does In-File Delta work?

In an incremental backup, only modified files will be uploaded to the Backup Server.

On the other hand, In-File Delta is applicable to the physical files to be uploaded to the
Backup Server, does not matter whether it is a MS SQL database file, MS Exchange
transaction log file or any normal file in a FileBackupSet. Specifically, only the changed blocks
in comparison to the original file on the Backup Server (delta file) will be uploaded.

For each modified file, AhsayOBM would determine whether the entire file or only delta file
should be uploaded. If the entire file is to be uploaded, the old version of the file will be
moved to the Retention area. Else if only the delta file is to be uploaded, the previous delta
files will be moved to the Retention area and the Data area should contain the original full
backup file, checksum file and the latest delta file of this file.

~Back to top
3.39. How does the “Auto” block size work under In-file Delta settings?

If the block size is set to “Auto”, the effective block size (Started from OBM v5.0.1.7) will be
chosen from the following table based on the file size of the updated file:

File Size Delta Block Size
0 - 500M 4k

500M - 2G 8k

2G - 8G 16k

8G - 15G 32k

> 15G 64k

~Back to top
3.40. What happens when we do In-File Delta backup on a directory?

When you do backup, the Ahsay Online Backup software will do the followings:

1. Check if any files are added, updated or deleted (the calculation of these files are
based on files having the same filename).

2. New files will be uploaded to the server in whole.

3. Deleted files will be removed from Data area and placed into the Retention area on
the Backup server.

4. Updated files will be processed by the In-File delta option (i.e. only changed data
blocks within the files will be uploaded to the Backup Server)

~Back to top

3.41. Does AhsayOBM have to stop the application when doing online
backups?

AhsayOBM can backup application data while the application is still running. Particularly, we
have special agents for MS Exchange Server, MS SQL Server, Oracle, Lotus Notes and MySQL,
which allows these applications to be backed up while they are online. With the Volume
Shadow Copy feature started from AhsayOBM v5.0, we are able to backup other types of
applications while they are online.

~Back to top

3.42. What are Off-line backup, Logout backup reminder and Local
backup features?

Off-line Backup is basically designed for notebook users who are off-line most of the time,
and cannot rely on backup schedule to backup regularly. The backup interval allows notebook
users to specify the interval that they would like their data to backup. If this interval has
elapsed, backup will run automatically once this machine is online.
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Logout Backup Reminder asks user if they would like to backup if they logout of the
computer or shutdown their computer.

Local Backup allows an extra copy of backup file to be kept on local hard disk when backup
is running.

~Back to top
3.43. Why is my AhsayOBM running backup once every hour?

You might have “Off-line backup” enabled for every hour. Please do the following to disable
that:

1. Logon to OBM

Select the backup set that you want to disable the Off-line backup from the left panel
Select the [Extra Backup] node under the backup set node on the left panel
Uncheck the [Enable off-line backup] checkbox under the “Off-line Backup” section

o kN

If you want to do this to all backup sets, please repeat the previous step for each
backup set

Press the [Save Setting] button from the toolbar

~Back to top
3.44. How do I disable “logout backup reminder”?

To disable the “System Logout Backup Reminder”, please do the followings:
1. Logon to AhsayOBM

2. Select the backup set that you want to disable the Logout reminder from the left
panel
3. Select the [Extra Backup] node under the backup set node on the left panel

4. Uncheck the [Enable System Logout Backup Reminder] checkbox under the “System
Logout Backup Reminder (Windows)” section

5. If you want to do this to all backup sets, please repeat the previous step for each
backup set

Press the [Save Setting] button from the toolbar
~Back to top
3.45. How do |l upgrade AhsayOBM from V4.5 on Linux?

Please do the followings for upgrade:
1. Shutdown backup scheduler by running "touch $OBM_HOME/ipc/Scheduler/stop™
Make this directory ~/.obm
Move old $OBM_HOME/log and $OBM_HOME/config to ~/.obm
Rename $OBM_HOME to $OBM_HOME.bak
Install new OBM to $OBM_HOME and expanding all files into $OBM_HOME

Run $OBM_HOME/bin/BackupManager.sh (or $OBM_HOME/bin/Configurator.sh if in
command line mode) to configure your backup set. All your old setting should still be
there.

oo ks wN

7. Run $OBM_HOME/bin/Scheduler.sh to startup backup scheduler (you must have run
$OBM_HOME/bin/BackupManager.sh or $OBM_HOME/bin/Configurator.sh once,
before starting up the scheduler)

~Back to top

3.46. How do I change the .obm path for Novell?
Please take a look at SYS:\OBM\home.txt. It contains the path to the .obm directory. You can
do the followings to make the changes:

1. Stop the scheduler
2. Change the entry in SYS:\OBM\home.txt to another directory
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3. Copy the .obm directory from existing location to new location
4. Startup the scheduler again

5. Also, open “SYS:\OBM\bin\BackupManager.ncf” and append the updated .obm path
to the end of the whole command line.
Example

java -mx384m -Djava.library.path=$LIB_PATH -cp $OBM_CLASSPATH obm
SYS:\OBM C:\[new location]\.obm

~Back to top

3.47. The MS SQL or MS Exchange database backup job stores 2 copies
of the spooled database file in the "temporary directory" (tagged
with different datetimes). This has taken up extra disk space, is this
necessary?

If you have interrupted any of the backup jobs, the file tagged with the datetime of the
corresponding backup job will be renamed to its original filename just before it is uploaded.
This is necessary as we need to ensure that the snapshot of different dates would not
overwrite each other.

If a backup job is still running, just let it runs to completion. If backup has been stopped
already, just remove all files tagged with the corresponding datetime in the “temporary
directory” and try to perform a full database backup again.

~Back to top
3.48. What do | have to do in order to backup open files?

You need to be on AhsayOBM v5.0 or above, as well as support from the underlying OS.
Windows XP and 2003, by default, come with Volume Shadow Copy, which allows backup
open file. For older platforms, e.g. Windows 9x/ME/NT/2000 or NetWare, we would
recommend adding a third party open file manager option (e.g. St. Bernard Open File
Manager - http://www.stbernard.com/) which might cost around US$100 for each
workstation and US$300 for each server if open file backup is required.

*QOpen file option is not required on Linux/Unix/Mac OS X because no files are held exclusively open by
applications.

~Back to top

3.49. How does Volume Shadow Copy work?

Please refer to:
http://technet2.microsoft.com/WindowsServer/en/Library/2b0d2457-b7d8-42¢3-b6¢c9-59c¢
145b7765f1033.mspx

~Back to top

3.50. In Windows, when AhsayOBM is creating Shadow Copy Set, it gets
the “|[ERROR] E_UNEXPECTED” error, what can |1 do?

This is a Microsoft Volume Shadow Copy issue. Microsoft's recommendation is to try
re-registering the Volume Shadow Copy Service. If you are on Win XP Pro, you can simply run
the batch file available in C:\Program Files\OBM\bin\RegisterVSS.bat or

http://download.ahsay.com/support/RegisterVSS.bat.

~Back to top
3.51. How to backup Oracle 7.3.4 on NetWare?

To backup Oracle 7.3.4 on NetWare 5.1, it is not possible to use the Oracle agent, you need
to do the followings:
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1. Backup all Oracle 7.3.4 datafiles, control files, and pfile.
2. Use "exp" (export utility) to dump Oracle database to a dump file (make this a

pre-backup command)
3. Use AhsayOBM to backup this file

When you need to restore the database, just restore all datafiles, control files, pfile to its
original location and use "imp" (import utility) to put the data back into Oracle database.

~Back to top
How do | backup NTFS permission?

For version 5.1 or later, NTFS permission is also backed up during the backup operation. For
other versions, please do the followings:

1. Download and install
http://www.microsoft.com/downloads/details.aspx?FamilyID=ESBA3E56-D8FE-4A9
1-93CF-ED6985E3927B&displaylang=en

2. Add a pre-backup command to dump the NTFS permissions of all files you want to
backup into a dump file. For example, if you want to have all files under C:\ drive to
a C:\NTFS-Permission.txt, please add:

"C:\Program Files\Windows Resource Kits\Tools\subinacl" /noverbose
/outputlog=C:\NTFS-Permission.txt /subdirectories C:\*.* /display

to your pre-backup command.
3. Add "C:\NTFS-Permission.txt" to the [Backup Source] of this backup set

~Back to top
How do | restore NTFS permission?

For version 5.1 or later, the backed up NTFS permission will be restored automatically. For
other versions, assuming the NTFS Permission is being stored in "C:\NTFS-Permission.txt",
please do the followings:

1. Restore "C:\NTFS-Permission.txt" from the backup server using OBM
2. Apply all NTFS permissions backup to all your backup files by running:

"C:\Program Files\Windows Resource Kits\Tools\subinacl" /playfile
C:\NTFS-Permission.txt

~Back to top
How do | backup file permission in Linux?

For version 5.1 or later, Linux file permission is also backed up during the backup operation.
For other versions, please do the followings:

1. Add a pre-backup command to dump the Access Control Lists of all files you want to
backup into a dump file. For example, if you want to have all files under /home to a
/ACL.txt, please add:

cd /; getfacl -R home > ACL.txt

to your pre-backup command.
2. Add "/ACL.txt" to the [Backup Source] of this backup set

~Back to top
How do | restore file permission in Linux?

For version 5.1 or later, the backed up Linux file permission will be restored automatically.
For other versions, assuming the Access Control Lists is being stored in "/ACL.txt", please do
the followings:
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1. Restore "/ACL.txt" from the backup server using AhsayOBM
2. Apply all Access Control Lists backup to all your backup files by running

cd /; setfacl --restore=ACL.txt
~Back to top

3.56. How do | remove AhsayOBM completely from my Windows
machine?

If you want to completely remove AhsayOBM from Windows, after uninstalling the software
from [Control Panel] -> [Add or Remove Programs], please do the followings:

° Ensure that the AhsayOBM installation directory is deleted (sometimes not removed
when Windows somehow holds some of the files)

L] Remove the C:\Documents and Settings\administrator\.obm\ folder (intentionally
left undeleted, as important information of the user and backup sets, such as the
encryption keys, are stored here)

~Back to top
3.57. Does AhsayOBM work with dial-up connections?

It makes no difference to AhsayOBM if the connection is always on or dial-up.

If you want Windows to connect to the ISP automatically when a backup starts, you can go to
[Control Panel] -> [Internet Options] -> [Connections] and select “Always dial my default
connection”.

~Back to top

3.58. The AhsayOBM crashes when opening [Backup Source] of a Lotus
Domino/Notes backup set, what can | do?

Check to see if you can find a hs_err_pid????.log file under the [OBM Home], and if it contains
the error "Unable to complete restart processing, err = Recovery Manager: Error from
Logging Subsystem", please do the followings:

1. Go to [Configuration], select [All Server Documents] and choose your corresponding
server.

2. [Disable] Transactional logging at Basics

3. Go to [Control Panel] -> [Administrative Tools] -> [Services] and restart [Lotus
Domain Server] Service

4. Go to [Configuration] -> select [All Server Documents] and enable Transaction
logging

5. Make sure your logging style is "Archived"
6. Go to [Services] and restart Lotus Domain Server Service again

~Back to top
3.59. How do I restore a machine from my SystemState backup?

To recovery a machine from scratch, you have to do the followings:

1. Re-install the operating system

2. Re-install all applications installed (You can do both of these easily by backing up the
system yearly using Norton Ghost)

3. Restore the SystemState backup onto the recovered machine (This will update the

recovered system with the latest configuration and settings)
4. Restore all data files onto the recovered system.

~Back to top
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4. Ahsay Offsite Backup Server (AhsayOBS)

4.1. What is the recommended hardware and Operating System
(Windows or Linux) for AhsayOBS?

As a rule of thumb, an active backup session takes roughly 1MB of memory. Therefore, a
512MB size of RAM can support around 500 active backup sessions. The required storage
space depends on the expected amount of backup data from your users, and it is possible to
make use of external storage server. Most processing is done on the client side, as a result
CPU utilization on the AhsayOBS machine shouldn’t be intensive. For your reference, in most
conditions, a P4 2.8GHz CPU with 1GB of RAM and lots of disk space (2-4TB of disk space) can
support up to 500 user.

AhsayOBS runs equally well on Windows and Linux platforms. You may want to go for a
platform that your system administrators are comfortable with. From the operating system
point of view, Linux might be more stable and require less maintenance.

~Back to top
4.2, What is the recommended bandwidth?

It really depends on the expected amount of data transfer from your users and the
performance criteria if any, of course, as well as your budget. For example, if your users
expected a transfer rate of up to 200MB per hour, and you project that 10 of such backups
will be running in parallel, then your AhsayOBS should have an uplink of around 5Mbps in
order to support such requirements.

~Back to top

4.3. Is there a limit on the number of clients that an AhsayOBS can
support? How many clients would you recommend per
AhsayOBS?

At the application level, there isn’t really a limit on the number of clients that an AhsayOBS
can support. However, the number of active clients could be limited by the hardware.
Specifically, each active backup session takes around 1MB of memory, so the number of
active clients is limited by the RAM available. Also, the bandwidth availability could also place
a limit on the number of active clients, as a rule of thumb, you can assume a 3:1 compression
ratio when backing up files and a throughput of 950MB per hour using an ADSL with 256kbps
uplink.

Anyhow, from system administration point of view, we would recommend having no more
than 2000 users on a single server.

~Back to top

4.4. What is the limit on file size that AhsayOBS can backup?

There is no limitation on the file size at the application level. Instead this limitation is imposed
by the underlying operating system. With modern operating system, you should have no
problem backing up files at a few TB in size (e.g. NTFS has a file size limit of 16TB).

~Back to top

4.5. How many users/licenses can | have on one server?

There is no limit on the maximum number of users. But from system administration point of
view, we would recommend having no more than 2000 users on a single server.

~Back to top

Ahsay Systems Corporation Limited Page 22 of 48 (May 22, 2009)



AHITI Ahsay Online Backup
We backup your business Technical FAQ

4.6. The Installer doesn’t seem to be working. How can | manually
install AhsayOBS on Windows?

You can manually install the AhsayOBS by downloading the upgrade pack (obs-win.zip) and
do the followings:

1. Create the directory C:\Program Files\Ahsay Offsite Backup Server
2 Unzip obs-win.zip to C:\Program Files\Ahsay Offsite Backup Server
3. Run C:\Program Files\Offsite Backup Server\bin\install-service.bat
4

Open your browser and point to http://localhost/ (if you cannot see the welcome
page, please check if port 80 and 443 are available. You can look at the log files
available in C:\Program Files\Ahsay Offsite Backup Server\logs for more information)

~Back to top
4.7. How do I install AhsayOBS on FreeBSD?

You can either run AhsayOBS on a Linux version of Sun Java JDK (performance might not be
optimized) or on a FreeBSD native Java SDK.

For the Linux version of Sun Java JDK option you need to:

1. Install Linux binary compatible port to the FreeBSD machine

2. Install the Linux version of Sun Java 1.4.2 or above JDK onto the FreeBSD machine

3. Create a symbolic link from $0OBS_HOME/jvm to $JAVA_HOME (installed in previous
step)

4. Run $0OBS_HOME/bin/startup.sh to startup AhsayOBS

For the FreeBSD native Java SDK option you need to:
1. Install Linux binary compatible port to the FreeBSD machine
2. Install the Linux version of Sun Java 1.4.2 or above JDK onto the FreeBSD machine

3. Compile the FreeBSD native Java 1.4.2 SDK using the JDK compiler installed in the
previous step

4. Install the FreeBSD native Java 1.4.2 SDK onto the FreeBSD machine
5. Create a symbolic link from $OBS_HOME/jvm to $JAVA_HOME (installed in previous
step)

6. Run $0OBS_HOME/bin/startup.sh to startup AhsayOBS
~Back to top

4.8. How to install AhsayOBS if ports 80 and 443 are already taken by
other applications?

AhsayOBS requires port 80 and 443 by default. You will have problems if these ports are
already taken by other applications.

You have a few options:
1. Free up port 80 and 443 for AhsayOBS

2. Configure AhsayOBS to run on other ports (refer to our Administrator's Guide)
3. Add one more IP to your server with the corresponding port 80 and 443 dedicated for
AhsayOBS

~Back to top

4.9. The AhsayOBS doesn’t seem to work, is this related to the
Microsoft Internet Information Server (lIS) running on the same
server?

The best way to run AhsayOBS and 1IS on the same machine is to have 11S and AhsayOBS
listening on port 80 and 443 of different IP addresses available on the same machine (please
note that you can bind more than 1 IP address to the same network card).
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Assumptions
1. The machine has 2 IP addresses, 192.168.1.1 and 192.168.1.2
2. You want to run IIS on port 80 and 443 of 192.168.1.1
3. You want to run AhsayOBS on port 80 and 443 of 192.168.1.2

Instructions

1 Configure 1S to listen to 192.168.1.1 address (please look at this article,
http://support.microsoft.com/kb/813368/en-us)

i Open [Start] -> [Administrative Tools] -> [Internet Information Service (11S)
Manager]

ii. Right click the [(Server Name)] -> [Web Sites] -> [Administration] node and
select [Properties]
iii. Open the [Web Site] tab and select [192.168.1.1] from the drop down list

2 To configure AhsayOBS to listen to port 80 and 443 of 192.168.1.2, please refer to
section 15.1 and 15.2 in our Administrator's Guide. It is available at
http://www.ahsay.com/en/doc/aobs-admin-guide.pdf.

3 Stop the [World Wide Web Publishing Service] service from [Start] ->
[Administrative Tools] -> [Services]

4 Stop the [Ahsay Offsite Backup Server] service from [Start] -> [Administrative Tools]
-> [Services]

5 Start the [World Wide Web Publishing Service] service from [Start] ->
[Administrative Tools] -> [Services]

6 Start the [Ahsay Offsite Backup Server] service from [Start] -> [Administrative Tools]
-> [Services]

Try browsing http://192.168.1.1/ and http://192.168.1.2/ to see if you can view two
different welcome pages from IIS and OBS respectively.

You can also use the "netstat -an" command to check the "LISTEN" status of different TCP/IP
entries to see if there are ports conflicts.

~Back to top

4.10. Is the 128-bit SSL secure enough to communication between
AhsayOBM and AhsayOBS?

Under most situations, 128-bit is already more than enough for commercial use (Please see
http://www.ahsay.com/en/product/aobs-security.htm). Also, encryption strength doesn't
rely solely on the number of bits used in the encryption. The choice of a random source and
random salt are just as important. In addition, the backup data is being encrypted and
compressed before sending over from AhsayOBM to AhsayOBS, which surely enhances the
security.

~Back to top
4.11. How is the data privacy being maintained on AhsayOBS?

All data are encrypted with user's defined encrypting key before they are sent to the online
backup server. The encrypting key is not stored on AhsayOBS. Without the encrypting key,
the backup files are useless to anyone. The backup user is the only person who can decrypt
the backup files to reveal the original content.

~Back to top
4.12. How do linstall a SSL certificate?

To replace the non-secure dummy SSL certificate with a secure SSL certificate on AhsayOBS,
please do the followings:

1. Identify the location of the keystore file. You need to store your SSL certificate in a
keystore file. The default location of the keystore file is:
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%INSTALL_DIR%\conf\keystore.

2. Delete dummy certificate from keystore. You can delete the dummy SSL certificate
from the keystore by running:

%INSTALL_DIR%\java\bin\keytool -delete -alias tomcat -keystore
% INSTALL_DIR%\conf\keystore

3. You will be prompted for the password for the keystore. The default password is
“changeit”.
4. Generate RSA key pair A SSL certificate contains a RSA key pair. You can generate a

RSA key pair by running:

%INSTALL_DIR%\java\bin\keytool -genkey -alias tomcat -keyalg RSA
-keysize 1024 -keystore
% INSTALL_DIR%\conf\keystore

5. Create a local Certificate Signing Request (CSR). You can create a CSR for your SSL
certificate by running:

% INSTALL_DIR%\java\bin\keytool -certreq -keyalg RSA -alias tomcat
-file ssl.csr -keystore %6INSTALL_DIR%\conf\keystore

6. Submit the CSR file to a trusted CA
7. Import signed SSL certificate from CA to the keystore :

% INSTALL_DIR%\java\bin\keytool -import -alias tomcat -trustcacerts
-file ssl.crt -keystore %6INSTALL_DIR%\conf\keystore

~Back to top

4.13. |am getting a “Failed to establish chain from reply” error when
trying to import a SSL certificate, why?

If you are getting the "keytool error: java.lang.Exception: Failed to establish chain
from reply"” message when importing the SSL certificate file from CA. Please try
double-clicking the ssl.crt file on Windows, and view all intermediate certificates being used
to sign your certificate. Then import all intermediate certificates (downloadable from your CA)
into your keystore file before importing your SSL certificate.

~Back to top
4.14. Can we customize the AhsayOBS?

Of course it is possible. You can refer to our Administrator's Guide the details.

~Back to top

4.15. Can we customize the contents of the AhsayOBS Management
Console as well as those of the email reports and reminders?

You can use the properties.xls, which comes with AhsayOBS, to generate all the properties
files that define content on AhsayOBS. Please follow the instructions below:

1. Open [OBS Home]\properties.xls
2 Go to worksheet [obs-jsp]

3. Make the desirable changes.
4

Press the [Generate] button on the top left hand corner inside the worksheet (all
properties files will be generated for you under obs-jsp directory)

5. Copy all generated properties files back to the [OBS Install
directory]\webapps\obs\WEB-INF\classes directory

6. Restart the backup service

~Back to top
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4.16. Can we customize the layout of the email sent to customers?

Unfortunately, this is not possible right now.

~Back to top
4.17. What is the purpose of the Retention area, can | disable it?

Deleted and modified files in the current backup are moved to the Retention area in
AhsayOBS, they will stay there as defined by the retention policy of the backup set. You can
restore those files that are still in the Retention area. The main purpose of the Retention
area is to facilitate retrieval of historical snapshots of a backup set.

Note that the data in the Retention area still counts towards your client’s quota and it stay
there as defined by your client’s retention policy.

Unfortunately, the Retention area cannot be disabled, at its minimum, your client can choose
to keep deleted files for 1 backup job.

~Back to top
4.18. Is there an example on how the Retention area works?

Suppose you have 10GB of initial data which grows by 200MB (0.2GB) per day, and on each
day 100MB (0.1GB) of the data is modified or deleted from the client machine. Assume he
takes the default retention policy setting, i.e. 7 days. Then,

Day 0: Data = 10G; Retention = O; Total quota used = 10G;
Day 1: Data = 10.2G; Retention = 0.1G; Total quota used = 10.3G;
Day 2: Data = 10.4G; Retention = 0.2G; Total quota used = 10.6G;

Day 7: Data = 11.4G; Retention = 0.7G; Total quota used = 12.1G;
Day 8: Data = 11.6G; Retention = 0.7G; Total quota used = 12.3G;
(The 0.1G from Day 1 is removed from the Retention area)
Day 9: Data = 11.8G; Retention = 0.7G; Total quota used = 12.5G;
(The 0.1G from Day 2 is removed from the Retention area)
..and so on

Therefore if data is not being modified or deleted frequently, then the size of Retention area
should be minimal.

~Back to top

4.19. s it possible to keep 5 years backup, if so, do | need to set the
retention policy to 1825 days?

Not necessarily, it depends on your backup requirements. If you need to be able to restore
any of the snapshots for those 1825 days, then yes, you need to set a simple 1825-day
retention policy.

On the other hand, let say if for each of the 5 years, he only needs the snapshots on 31
December. Then you can make use of the "Advanced Retention Policy"” feature, where you
have options to keep yearly, quarterly, monthly, weekly or daily snapshots. With this
flexibility, you should be able to configure your desired backup policy.

~Back to top

4.20. Unmodified files are not uploaded to OBS regularly. Is this
acceptable?

For example:

If files were uploaded 90 days ago and the retention area was 90 days, does this mean they
get removed with the retention area cleanup and are scheduled for backup again the next
day?

Only files that have been deleted (or have been updated by a newer version) are stored in the
Retention Area. All other files stay in the Data Area as the current copy and they are not
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affected by the retention policy. In other words, unmodified files will stay on the AhsayOBS
forever.

~Back to top
4.21. Can lincrease the quota of Trial accounts on my AhsayOBS?

Trial accounts can only have a maximum of 500MB and they don't count towards your paid
licenses. It is not possible to have trial accounts with more than 500MB quota.

If you want to have a larger quota for potential clients to evaluate the software, you will have
to create Paid accounts for them.

~Back to top
4.22. How can I stop arunning backup job from AhsayOBS?

Unfortunately, AhsayOBS is passive and there is no way for you to stop a running backup job
from the server side. You have to do it on the client side.

~Back to top

4.23. AhsayOBS is not functioning properly, backup jobs stop in the
middle of the process, why?

Please check if you have any antivirus or personal firewall software installed. If so, please
disable it from scanning the online-backup-related data and traffic.

~Back to top

4.24. After a seed copy, the disk space used is not reflected in the user
statistics on AhsayOBS. Do | need to manually update the OBS
statistics?

Storage statistics will be rebuilt automatically every week. The scheduled time is specified
under [Manage System] -> [Routine Job] page, you can rebuild user storage statistics
immediately by changing it to the current time.

~Back to top
4.25. Is there atool to verify integrity of the backup data on AhsayOBS?

The Ahsay Online Backup software already has a built-in checksum mechanism. When a file
is uploaded, the Backup server would verify the checksum before marking it as a successfully
transferred file.

In addition, there is a weekly "Rebuild User Storage" batch job, configurable under
[Manage System] -> [Routine Job] -> [System Job] section in the AhsayOBS Management
Console. This routine job will only run when you selected the [Enable] option. This is to
ensure that all backup files have validated and no errors occurred when users needed to
restore.
The settings are as follows:

° Enable File Validation

» Verify “Filesize & Checksum" - Verify the backup file size with its expected values,
and the checksum of the backup file with the value saved during upload

» Verify “Filesize Only” — Only verify the backup file size with its expected values

*Note that if the [Enable File Validation] is uncheck, it would not validate if the actual file size has
changed.

o Corrupted File Action
» "Log information only" - Just log it in system log and do nothing

» "Move to retention dir" - Back it up in [User Homes]\[User Login]\errFiles and
remove this file from the Data area

Ahsay Systems Corporation Limited Page 27 of 48 (May 22, 2009)



AH Ahsay Online Backup
We backup your business Technical FAQ

Note that all these actions will be logged in [Manage Log] -> [System Log].

~Back to top
4.26. How do | backup an AhsayOBS?

You can use Ahsay Replication Server to backup the data in an AhsayOBS. This offers a
close-to-real-time backup of the AhsayOBS.

Alternatively, you can manually backup the following directories:
° The program directory (default directory is shown below):
» Windows: “C:\Program Files\Ahsay Offsite Backup Server”
»  Linux: “/usr/local/obs”

» Mac OS X: “/Applications/Ahsay Offsite Backup Server” and
“/System/Library/Startupltems”

*These directories contain relatively static data. You can backup this directory easily using any CD/DVD
burning software available in the market.

L] The [System Home] directory in AhsayOBS (this can be found in the [Manage System]

-> [System Home] entry after you have logged onto the administrative interface of
AhsayOBS)

L] All [User Homes] directories in AhsayOBS (this can be found in the [Manage System]
-> [User Homes] entries after you have logged onto the administrative interface of
AhsayOBS)

* Both [System Home] and [User Homes] directories contain more dynamic data. To ensure that you have
a consistent image of all files within this directory, please shutdown the backup service (or at least make
sure backup activities are not very active) when backing up your AhsayOBS.

~Back to top
4.27. How do I rebuild OBS from a backup?

To rebuild an OBS from backup, please do this:
L] Restore the program directory (the default location is shown below)
» Windows: “C:\Program Files\Ahsay Offsite Backup Server”
»  Linux: “/usr/local/obs”

» Mac OS X: “/Applications/Ahsay Offsite Backup Server” and
“/System/Library/Startupltems”

° Restore the [System Home] directory (back to its original directory if possible)
° Restore all [User Homes] directories (back to their original directories if possible)

If you have restored the [System Home] directory or any of the [User Homes] directories to
another directory (instead of the original directory), please open

° Windows: “C:\Program Files\Ahsay Offsite Backup
Server\conf\localhost\config\obs.xml”

L] Linux: “/usr/local/obs/conf/localhost/config/obs.xml”
L] Mac OS X: “/Applications/Offsite Backup Server/conf/localhost/config/obs.xml”

Modify the <system-home=> and/or <user-home=> parameters within the obs.xml file to
reflect the correct paths for these directories.

For Windows, run “C:\Program Files\Ahsay Offsite Backup Server\bin\Install-Service.bat” to
install AhsayOBS as Windows services.

Lastly, startup the backup services

~Back to top

4.28. How do | move backup data to a new AhsayOBS?

Please do the followings to backup data:
For AhsayOBS version 4.6
° Install a new copy of AhsayOBS on the new server
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® Copy:
[Old OBS Home]\conf \localhost\config\*.xml
to

[New OBS Home]\conf\localhost\config\*.xml

L] Copy the directory stated in [Manage System] -> [System Home] and [Manage
System] -> [User Home] to the new server

® Open:
[Old OBS Home]\conf\localhost\config\obs.xml
and modify the "system-home" and "user-home" parameters accordingly.

L] Startup the new AhsayOBS. You should be able to see all users on the new server.

For AhsayOBS version 5.0 or above

L] Install a new copy of AhsayOBS on the new server
® Copy:

[Old OBS Home]\conf\*.xml

to

[New OBS Home]\conf\*.xml
o Copy the directory stated in [Manage System] -> [System Home] and [Manage
System] -> [User Home] to the new server

L] Open:
[Old OBS Home]\conf\obs.xml
and modify the "system-home" and "user-home" parameters accordingly.

L] Startup the new AhsayOBS. You should be able to see all users on the new server.
~Back to top

4.29. What do | have to do when changing the IP address of the
AhsayOBS?

If you are using an IP address currently instead of a domain name, you need to ask your
clients to logon to the server by specifying the new IP address in the AhsayOBM. They also
need to restart their Ahsay Online Backup Scheduler services. Therefore, it is a good idea to
use domain name instead.

~Back to top

4.30. How do I move an AhsayOBS installation from one directory to
another directory (Windows)?

To move an AhsayOBS installation from one directory (%OLD_DIR%, e.g. C:\Program
Files\Ahsay Offsite Backup Server) to another directory (%oNEW_DIR%, e.g. D:\Program
Files\Ahsay Offsite Backup Server), please do this:
° Shutdown the backup service from [Administrative Tools] -> [Services] -> [Offsite
Backup Server]
° Run [%0OLD_DIR%]\bin\remove-service.bat to remove the [Ahsay Offsite Backup
Server] service from [Administrative Tools] -> [Services]
° Move everything in [%OLD_DIR%] to [%oNEW_DIR%]
[ Open:
(OBS v4.0) [%NEW_OBS_HOME%]\conf\localhost\config\obs.xml
(OBS v5.0 or above) [%6NEW_OBS_HOME%]\conf\obs.xml
and correct the "system-home" and "user-home" parameters if they are changed
as a result of this relocation
° Run [%NEW_DIR%]\bin\install-service.bat to install the [Ahsay Offsite Backup
Server] service to [Administrative Tools] -> [Services]

L] Startup the backup service from [Administrative Tools] -> [Services] -> [Ahsay
Offsite Backup Server]

~Back to top
4.31. How do I move my AhsayOBS to a new server?

Please do the followings to move the AhsayOBS to a new server:
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1.

6.

7.

Re-Install the AhsayOBS to a new server (the default location is shown below)
» Windows — “C:\Program Files\Ahsay Offsite Backup Server\”

» Linux — “/usr/local/obs”

» Mac OS X — “/Applications/OBS” and “/System/Library/Startupltems”

Start the AhsayOBS from the new server and enter your License Key (you should
received an “Internal error no. 1011”, that means you’ll have 7 days grace period
before your new AhsayOBS server expired).

*Note: One license key can only activate a single machine. Please shutdown the backup service
on the first server you have this license key installed. And please contact us with your "License
Name" and "License Key", our system administrator will update the license server to allow your
key to be used again

Copy the [System Home] directory to the new server (back to its original directory).
The default location is shown above.

Copy the [User Homes] directories to the new server (back to its original directory).
The default location is shown above

If you have stored the [System Home] directory or any of the [User Homes]
directories to another directory (instead of the original directory), please open

» Windows — “C:\Program Files\AhsayOffsite Backup Server\conf\obs.xml”
» Linux — “/usr/local/obs/conf/obs.xml”
» Mac OS X — “/Applications/OBS/conf/obs.xml”

Please modify the “and/or” parameters within the [obs.xml] file to reflect the correct
paths for these directories.

(For Windows) Run [C:\Program Files\Ahsay Offsite Backup
Server\bin\Install-Service.bat] to install AhsayOBS as Windows services.

Startup the backup services

~Back to top

4.32. How do I move users between different “User Homes” ?

Assuming you want to move a user to a new drive (e.g. from [OBS Home]\user to [New
Home]\user), then you need to:

1.
2.

3.
4.

5.

Logon to the AhsayOBS Management Console as the administrator

Under the [Manage System] page, enter another [User Homes] (in this case, [New
Home]\user) in the [New] textbox provided and press the [Update] button

Shutdown the Backup service

Move the user directory to the new user home (e.g. [OBS Home]\user\xxxx -> [New
Home]\user\xxxx)

Startup the Backup service

~Back to top

4.33. How do I rename a backup account on AhsayOBS?

You can do the followings:

1.
2.

3.

4.

Shutdown the Backup service
Identify the corresponding user directory in [User Homes], and rename it to the new
login name (e.g. from "old_name" to "new_name")
Open [User Homes]\[new_name]\db\Profile.xml and change the login name from
"old_name" to "new_name", namely:
<ROOT><USER LOGIN_NAME="old_name"
to
<ROOT><USER LOGIN_NAME="new_name"
Startup the Backup service

* If there are existing installations of AhsayOBM running with the old login name, you need to logon to
those AhsayOBMs with your new login name and restart the "Ahsay Online Backup Scheduler"” service.

~Back to top
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4.34. Can | change the Backup Client type between AhsayACB User and
AhsayOBM User?

Provided that you have adequate CALs for the corresponding type, you can always switch an AhsayACB
user to an AhsayOBM user. However if you want to switch an AhsayOBM user to an AhsayACB user, you
need to follow the instructions below, to trim down the corresponding AhsayOBM account.

The backup set you are migrating to AhsayACB must be a file backup set. Through the AhsayOBS Web
Management Console:

1.

AN

Remove any extra backup sets from the AhsayOBM account
Remove all schedules from this backup set

Remove any advance retention policy settings from this backup set
Remove any advance in-file delta settings from the backup set

Under [Manage System] -> [Manage User] -> [%USERNAME] -> [User Profile] change the
backup client type to "AhsayACB User" and [Update] to convert the account to an AhsayACB
account.

~Back to top

4.35. Is it possible to move backups from one account to another? Can
the data be merged into an existing account?

It is possible, suppose you want to move a backup set from account A to account B, then you
can do the followings:

1.

g h N

7.

Create a backup set in account B, and its backup configuration needs to be similar to
the backup set in account A

Upload some arbitrary files to the backup server using this backup set
Shutdown the backup server service
Delete all files under [User Home]\[Account B]\files\[BackupSetID]

Copy the backup data from [User Home]\[Account A]\files\[OldBackupSetID] to
[User Home]\[Account B]\files\[BackupSetID]

Schedule the [Manage System] -> [Routine Job] -> [Rebuild User Storage] job to a
more recent time to update the user storage information

Start the backup server service.

~Back to top

4.36. Backup accounts on my AhsayOBS are disappearing, why?

Please do the followings to check if there is any file corrupted:

1.

Go to the log directory
(AhsayOBS v4.6) [OBS Home]\conf\localhost\logs
(AhsayOBS v5.0 or above) [OBS Home]\logs
Check the latest obs*.log file

Scroll to the bottom and check if there is a "Profile Corrupted" or "User does not
exist" error message

If error message exist, please go to [User Homes]\[Login Name]\db directory and
check if Profile.xml is missing (or corrupted).

i. If the Profile.xml file is missing, please use the backup copy (e.g. Profile.xml.1) to
recreate a new Profile.xml file.

ii. If the Profile.xml file is corrupted, (Make sure the file is not empty and the XML
document is complete) please use the backup copy (e.g. Profile.xml.1) to
recreate a new Profile.xml file.

Please also check Profile.xml file, whether the case "login ID" has the same name as
the user folder. For example, if login ID is 'backupl' and the folder name is
'‘Backupl’, then you should change the folder name to the same case as the login ID.

If not all the backup accounts are not listed out, please go back to step 2 and check
if there is another corrupted profile.

~Back to top
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4.37.

4.38.

4.39.

4.40.

When trying to setup AhsayOBS on Windows with the “User
Homes” pointing to an external NAS device. It says “Access
denied” when try to create a new user account. What can 1 do?

AhsayOBS runs as a Windows service under the LocalSystem account. Unlike the
Administrator account, the LocalSystem account has full access to everything on the local
machine, however it does not know where mapped drives (e.g. S:\) are mapped and it has
NO access privilege to any network resources by default.

You need to do the followings:

1. Use UNC path (e.g. \\Server\Share) instead of mapped drive as your “User Homes”
directory (i.e. [Manage System] -> [User Homes] on the AhsayOBS Management
Console)

2. Open [Control Panel] -> [Administrative Tools] -> [Services] -> [Offsite Backup
Server] -> [Log on]

3. Select the [This Account] option

4. Enter an account and password that has access privilege to the UNC path specified
above

5. Restart the [Ahsay Offsite Backup Server] services

~Back to top

The [Backup Job] drop down menu on the [Report] page from the
AhsayOBS Management Console is showing an empty list. What
can ldo?

Please check the server log files in [OBS Home]\conf\localhost\logs\obs*.log and see if you
can find any error messages.

Also, check the [User Home]\[Login Name]\db\BackupSet\[BackupSet ID]\*.log to see if you
find any filenames not in the yyyy-MM-dd-HH-mm-ss.log format. If yes, just delete them.

~Back to top

Why do | receive multiple reports from the same backup job on
AhsayOBS Management Console?

If you are seeing multiple reports from the same backup job on AhsayOBS Management
Console, sometimes both “failed”; sometimes one “successful”, one “failed”; and sometimes
both “successful”. You may have installed the client software on more than 1 computer
using the same backup account? If so, all instances of the client software will run the same
backup job at scheduled time and therefore cause this problem.

To fix this problem, please disable running irrelevant scheduled backup job on each computer.
(Please refer to the website:
http://download.ahsay.com/support/screenshots/ScheduledBackup.jpg).

~Back to top
How do | setup AutoUpgrade?

1. Download http://download.ahsay.com/support/obm50-live-upgrade.zip

2. Unzip the downloaded file to the live upgrade directory on the backup server.
The default locations of the live upgrade directory are:

» Windows — C:\Program Files\Ahsay Offsite Backup
Server\webapps\obs\liveUpdate

» Linux — /usr/local/obs/webapps/obs/liveUpdate

» Mac OS X — /Applications/OBS/webapps/obs/liveUpdate
3. If you are on a customized AhsayOBM, you need to:

» Replace all *.properties files with you customized version

» Replace all *.gif files with you customized version
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» Replace all *.ico files with you customized version

Auto Upgrade from v4.6.x to v5.0.x will be performed in two steps before running any
scheduled backup job:

1. Auto Upgrade of all v4.6.x client software to v4.6.2.0

2. Auto Upgrade of v4.6.2.0 client client to v5.0.1.x (after restarting backup scheduler
or restarting the computer)

If you run into any problems, please take a look at the scheduler log

For Windows:

(v4.5) C:\Program Files\AhsayOBM\log\Scheduler\debug.log
(v4.6, v5.0) C:\Documents and Settings\Administrator\.obm\log\Scheduler\debug.log

(v4.5) /usr/local/obm/log/Scheduler/debug.log
(v4.6, v5.0) ~/.obm/log/Scheduler/debug.log

Mac OS X:

(v4.5) /Applications/OBM/log/Scheduler/debug.log
(v4.6, v5.0) ~/.obm/log/Scheduler/debug.log

*All pre v5.0.1.3 releases (only for v5.0) of OBM have a bug that causes auto upgrade to stop working until
v5.1 is available. If you need to upgrade all pre v5.0.1.3 releases to the latest release, please upgrade
the existing installation manually or wait until v5.1 is available.

~Back to top

4.41. My clients have auto-upgraded to a wrong AhsayOBM, how could |
force another AutoUpgrade?

You can force the AutoUpgrade to run by modifying the index.xml, for:
L] Windows — C:\Program Files\Offsite Backup Server\webapps\obs\liveUpdate
L] Linux — /usr/local/obs/webapps/obs/liveUpdate
° Mac OS X — /Applications/OBS/webapps/obs/liveUpdate

You can modify the 2 lines in index.xml as described below:
1. Update compatible="4.6" version="4.6x" url="/obs/liveUpdate/obm4622a.zip"

2. Update compatible="4.6,5.0" version="5.0.2.1"
url="/obs/liveUpdate/obm5021.zip" crc="-1" last-modified="0" size="-1"

~Back to top

4.42. Why do | have problem in restoring through the restorer applet on
the OBS Management Console?

If you have problems restoring backup files from the backup server, please try the followings:
1. Make sure the decrypting key is entered correctly in exactly the same case

2. Make sure that the [Manage User] -> [Backup Set] -> [Online Restore IP restriction]
setting is correct (if you don't want to enable this option, there shouldn't be more
than 1 row under this section)

3. Install Sun Java JRE 1.4.2 or above onto the machine from which you are restoring
your backup files and tries restoring again.

4. Check the log entries available in the [Java Console] accessible from the system tray
area

5. Check the following server log files on the backup server:

» (AhsayOBS v4.6 or before) C:\Program Files\Ahsay Offsite Backup
Server\conf\localhost\logs\obs*.log
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» (AhsayOBS v5.0 or above) C:\Program Files\Ahsay Offsite Backup
Server\logs\obs_context*.log

~Back to top

4.43. Why do | have problem in restoring large amount of files through
the restorer applet on the AhsayOBS Management Console?

Please try increasing the maximum amount of memory available to the restorer applet to
512MB by following the steps below:

For Java 1.5x

1. Open [Java Control Panel] from [Control Panel] -> [Java]
2. Press the [Java] -> [Java Applet Runtime Setting] -> [View] button
3. Enter "-Xmx512m" (without the quote) into the [Java Runtime Parameters] box of

the version of JRE in use
4. Restart all browser instances and try restoring again

For Java 1.4x

1. Open [Java Control Panel] from [Control Panel] -> [Java Plug-in]

2. Press the [Advanced] tag and select the version of JRE in the Java Runtime
Environment

3. Enter "-Xmx512m" (without the quote) into the [Java Runtime Parameters] box and
press "Apply*

4. Restart all browser instances and try restoring again

~Back to top

4.44. How do | sign the restorer applet on my customized AhsayOBS?

Basically, the applet that you need to sign is:

° Windows — C:\Program Files\Offsite Backup
Server\webapps\obs\jsp\applet\obr\obrA.jar

° Linux — /usr/local/obs/webapps/obs/jsp/applet/obr/obrA.jar
L] Mac OS X — /Applications/OBS/webapps/obs/jsp/applet/obr/obrA.jar

The restorer applet signing instructions below are for you reference, you may need to refer to
the documentations from the CA where you purchased your code signing cert:

1. To prevent messing up the original keystore for OBS, we recommend you to make a
copy of your keystore. Then use the keystore-copy to generate a CSR.

Use the generated CSR to purchase a JavaSoft code signing cert from your CA.
Import the issued cert back into the keystore-copy.

Backup [obrA.jar] in case you need to reinstate the applet

Rename [obrA.jar] to [obrA.zip]

Open up the zip file and delete the [META-INF] folder

Rename [obrA.zip] back to [obrA.jar]

user “jarsigner.exe” command to sign the applet with your cert:

® N oA~ wDN

[OBS_HOME]\java\bin\jarsigner —keystore “[path of your keystore-copy]”
[OBS_HOME]\webapps\obs\jsp\applet\obr\obrA.jar [alias for your cert in the
keystore-copy]

9. Restart all instances of your browser and try restoring files from the [File Explorer]
page. You should now see your company hame in the dialog box prompted.
~Back to top

4.45. How do I remove pending emails from AhsayOBS?

You can simply remove:
[System Home]\PendingEmail\*
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Where

[System Home] = AhsayOBS system home directory
(default location is [OBS Home]\system)

~Back to top
4.46. Is there any documentation on the APIs?

Please refer to our Administrator’s Guide.

~Back to top

4.47. Why do | have problem in License activation/Report sending? It
gives “Invalid argument or cannot assign requested address” error
message.

If you are running AhsayOBS on Linux Kernel 2.6, you could have run into the IPv6
compatibility problem of running Java program on Linux Kernel 2.6 (More info on:
http://www.jroller.com/page/dissonance/20050630#fedora_core_4 and_jdk)

Please try the followings to fix the problem:
6. Open [$0OBS_HOME/bin/startup.sh]

7. Add “-Djava.net.preferlPv4Stack=true” to the command line argument. i.e. change
the line:

export CATALINA_OPTS="-Xms64m -Xmx512m -client
-Dsun.net.inetaddr.ttl=10800 -Dnetworkaddress.cache.ttl=10800
-Dsun.net.inetaddr.negative.ttl=0 -Dnetworkaddress.cache.negative.ttl=0"

to

export CATALINA_OPTS="-Xms64m -Xmx512m -client
-Dsun.net.inetaddr.ttl=10800 -Dnetworkaddress.cache.ttl=10800
-Dsun.net.inetaddr.negative.ttl=0 -Dnetworkaddress.cache.negative.ttl=0
-Djava.net.preferlPv4Stack=true"

8. Restart the backup service by running [$OBS_HOME/bin/shutdown.sh] and then
[$OBS_HOME/bin/startup.sh]

~Back to top
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5. Ahsay Replication Server (AhsayRPS)

5.1. How does AhsayRPS work?

AhsayRPS provides close to real-time backup to multiple AhsayOBSs.

The replication process can be in [UNSYNC], [SYNC] or [LOGGING] mode. To understand the
meanings of these replication modes, it is important to understand how data gets replicated
to AhsayRPS from AhsayOBS.

1.

Refreshing File — When AhsayOBS module started up, it first replicates AhsayOBS
program binaries and configuration files to AhsayRPS in its [Refreshing File] mode.
No backup data under [System Home] and [User Homes] will be replicated to
AhsayRPS by this task.

UNSYNC Replication — After the replication module has finished replicating all
program binaries and configuration files, it will start replicating all files under the
[System Home] and [User Homes] directories to AhsayRPS. During the execution of
this task, transaction logging of AhsayOBS is disabled. Backup data write directly and
only to the backup files.

SYNC Replication — Since it could take hours (or even days) to replicate all backup
data from AhsayOBS to AhsayRPS, by the time all files under [System Home] and
[User Homes] are worked through once, some files might have been added to or
removed from the OBS resulted from backup jobs ran during the UNSYNC mode.
AhsayOBS will then go into a SYNC mode, which has the following effects:

» System data generated by AhsayOBS will now be saved to the transaction log files
instead of to files under the [System Home] directory.

» There will be no changes to all files under the [User Homes] and [System Home]
directories

» Before leaving the SYNC mode, AhsayOBS replication module will replay all
transaction logs recorded to its supposed target files in the [User Homes] and
[System Home] directories.

Upon the completion of these tasks, both AhsayOBS and AhsayRPS will then be
synchronized. AhsayOBS should have all transaction logs replayed into the [User
Homes] and [System Home] directories. Although the [User Homes] and [System
Home] directories on AhsayRPS doesn’t contains the changes after all transaction
logs has been replayed, synchronization can be easily done by replicating the
transaction log files over from AhsayOBS to AhsayRPS and replaying these
transaction logs on RPS as it has been done on AhsayOBS.

Transaction Logs Replication — In this mode, backup data are written directly to the
backup files that they are supposed to go to as well as to the transaction log files. The
transaction log files recorded after the beginning of the SYNC period are then
transferred and replayed to AhsayRPS. When there are no backup activities and all
pending transaction log files have been replicated to AhsayRPS, transaction log files
are replicated to AhsayRPS every 5 minutes (even when it is empty). This will ensure
that partial records within the transaction log files get replicated to AhsayRPS in close
to “real” time.

Weekly RESYNC — To ensure that the replication server is in full sync with the backup
server after lots of transaction logs have been applied on the replication server, a
weekly RESYNC job will run every Sunday at 12:00pm (noon) automatically. This
involves running “Refreshing Files”, “UNSYNC Replication” and “SYNC replication”
described above all over again.

~Back to top

5.2. How should | configure my AhsayRPS-AhsayOBS pair?

Assume AhsayRPS is running with the following configuration:

Host: rps.your-company.com
HTTP port for web traffic: 9080
HTTPS port for web traffic: 9443
Port for replication traffic: 8444

You should then setup [AhsayRPS] -> [Manage Receiver] page with the following values:

Enable Replication = Checked
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Login Name = OBS (matches with that of the OBS)

Password = OBS (matches with that of the OBS)

Alias = Receiver for OBS

Home Directory = D:\ReplicatedData (specific for the particular OBS)
Listen Host = 0.0.0.0

Listen Port = 8444

Use SSL = Yes

Use Compression = Yes

And you should setup [AhsayOBS] -> [Manage System] -> [Replication Config] page with the
following values:

Enable Replication = Checked

Username = OBS (matches with that of the RPS)
Password = OBS (matches with that of the RPS)
Target Host = rps.your-company.com

Port = 8444

Use SSL = Yes

Use Compression = Yes

~Back to top

5.3. | have a large amount of data to be replicated to AhsayRPS, is there
a Seed Load facility for AhsayOBS?

Yes

, you can seed load the desired AhsayOBS by doing the followings:

Assumptions

1.
2.

3.

AhsayOBS is installed in "C:\Program Files\Ahsay Offsite Backup Server"
[AhsayOBS] -> [Manage System] -> [System Home] is configured to be
"D:\SystemHome"

There are 3 [AhsayOBS] -> [Manage System] -> [User Homes] settings. They are
configured to be "E:\UserHome1l1", "F:\UserHome2" and "\\Serverl1\UserHome3"
respectively.

The [RPS] -> [Manage Receiver] -> [Profile] -> [Home Directory] setting for the
AhsayOBS above is configured to be "G:\Receiver-Home"

Instructions

1. Shutdown the Ahsay Replication Service by stopping the [Control Panel] ->
[Administrative Tools] -> [Services] -> [Replication Server] on AhsayRPS

2. Disable the replication module by unchecking the [Manage System] -> [Replication
Config] -> [Enable Replication] checkbox on AhsayOBS

3. Copy all files in "C:\Program Files\Ahsay Offsite Backup Server", "D:\SystemHome",
"E:\UserHome1", "F:\UserHome2" and "\\Server1\UserHome3" to a removable hard
disk.

4. Ship the removable to the remote location where AhsayRPS is installed

5. Copy all files in the removable hard disk to "G:\Receiver-Home" AhsayRPS using the
following mappings:
» "C:\Program Files\Ahsay Offsite Backup Server" ->

"G:\Receiver-Home\files\C%3A\Program Files\Ahsay Offsite Backup Server"
» "D:\SystemHome" -> "G:\Receiver-Home\files\D%3A\SystemHome"
» "E:\UserHomel" -> "G:\Receiver-Home\files\E%3A\UserHome1"
» "F:\UserHome2" -> "G:\Receiver-Home\files\F%3A\UserHome2"
»  "\\Serverl\UserHome3" ->
"G:\Receiver-Home\files\%5C%5C\Server1\UserHome3"
Note

° The ":" sign in all windows drives are replaced by "%3A"

L] The "\\" sign in all UNC paths are replaced by "%5C%5C"

° All other files on AhsayOBS with name containing other characters can be copied "as
is" to AhsayRPS without any changes

° For Linux, the basic concept is the same, except that all paths are in the Linux

convention.
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6. After all files has been copied over to AhsayRPS, please check if the last modified time
of all files copied over are the same as they are on AhsayOBS
7. Startup the Replication Service by starting the [Control Panel] -> [Administrative

Tools] -> [Services] -> [Replication Server] on AhsayRPS

8. Enable the replication module by checking the [AhsayOBS] -> [Manage System] ->
[Replication Config] -> [Enable Replication] checkbox on AhsayOBS

9. Use [AhsayOBS] -> [Manage Log] -> [Replication Log] and [AhsayRPS] -> [Manage
Receiver] -> [Replication Log] pages to keep track of the running status of the
replication. Please make sure no files are being deleted on the replication server.

~Back to top

5.4. Is there a method to avoid replicating the moved “User Home” to
AhsayRPS all over again?

If you have moved a “User Home” on AhsayOBS, and don’t want to replicates the moved
“User Home” again. Please try the followings:

Recommended software version

AhsayOBS: v5.0.2.1 or above
AhsayRPS: v5.0.2.2 or above

Background

You have some data store in a local drive (with drive letter E:\) or any other drive. After
doing several backup and replications, you want to replace the local drive with a NAS device
for which an UNC path (i.e. \\servername\share) needed to be used instead of the drive
letter.

Now, since changing the drive name would cause all backup files to be replicated to
AhsayRPS all over again (even the data stored is the same as before) and you certainly do
not want this to happen, you’d just want it to continue with the current replicated data
already existed in the AhsayRPS.

Assumptions

You have set the user home path to be “E:\UserHome” to store the users’ data so that you
have something like this in your AhsayOBS:

E:\UserHome\John\db\...

E:\UserHome\John\files\...

E:\UserHome\Peter\db\...

E:\UserHome\Peter\files\...

You have set the system home path to be “D:\ReceiverHome” to store the replicated data.
Since some replications were done before, you have something like this on your RPS:
D:\ReceiverHome\files\E%3A\UserHome\John\db\...
D:\ReceiverHome\files\E%%3A\UserHome\John\files\...
D:\ReceiverHome\files\E2%3A\UserHome\Peter\db\....
D:\ReceiverHome\files\E%%3A\UserHome\Peter\files\....

You want to move the user home from the local drive E:\ to the NAS device without
replicating those data that is already replicated to AhsayRPS from AhsayOBS all over again

Instructions:
1. Shut down both AhsayRPS & AhsayOBS
2. On the AhsayOBS:
i. Copy all the user data stored in E:\UserHome to \\Server\Share\UserHome.

ii. Configure the new user home path through the AhsayOBS Management Console
(i.e. using UNC path instead of the drive letter).

After doing so, you should have the following changes as results:

Before: After:

E:\UserHome\John\db\... \\Server\Share\UserHome\John\db\...
E:\UserHome\John\files\... \\Server\Share\UserHome\John\files\...
E:\UserHome\Peter\db\... \\Server\Share\UserHome\Peter\db\...
E:\UserHome\Peter\files\... \\Server\Share\UserHome\Peter\files\...

2 2\ Z

3. On the RPS:
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i. Under the same folder level of the directory ‘E%3A’, create a new directory ‘_’
which represent the ‘\\' part of the UNC path. Then, inside this ‘_’ directory, create
the ‘Server’ directory and similarly for ‘Share’ & ‘UserHome’ directory.

ii. Move the whole directory of one of the user, say, ‘John’ in
D:\ReceiverHome\files\E%3A\UserHome to the new directory
D:\ReceiverHome\files\_\Server\Share\UserHome .

iii. Repeat step 3(ii) for the rest of the users.

Having done that, you should have the following changes as results:

Before

D:\ReceiverHome\files\E%3A\UserHome\John\db\... >
D:\ReceiverHome\files\E%%3A\UserHome\John\files\... >
D:\ReceiverHome\files\E%%3A\UserHome\Peter\db\.... >
D:\ReceiverHome\files\E2%3A\UserHome\Peter\files\.... >

After

- D:\ReceiverHome\files\_\Server\Share\UserHome\John\db\....

- D:\ReceiverHome\files\_\Server\Share\UserHome\John\files\....
- D:\ReceiverHome\files\_\Server\Share\UserHome\Peter\db\....

- D:\ReceiverHome\files\_\Server\Share\UserHome\Peter\files\....

4. Start up both AhsayRPS & AhsayOBS.
The existing ‘E%3A’ in AhsayRPS will be deleted automatically during the next replication.

*Note: Before making the above modifications, it is recommended to backup the data in case you might
have done something wrong.

~Back to top
5.5. My replication pair is not working, what can | do?

Please do the followings:

1 Check if you can access the AhsayRPS service by running the following command on
AhsayOBS: “telnet [RPS hostname] 8444”. If you get “connection refused”, then you
have problems connecting to the replication service.

2 Check your firewall settings to see if port 8444 is blocked

3 Restart the [Contron Panel] -> [Administrative Tools] -> [Services] -> [Offsite
Backup Server] on AhsayOBS and the [Contron Panel] -> [Administrative Tools] ->
[Services] -> [Replication Service] on AhsayRPS

4 Check if "Enhanced Security Configuration" for the Internet Explorer enabled. If so,
please disable it from [Contron Panel] -> [Add/Remove Software]

5 Contact us if you are still having problem
~Back to top
5.6. How can | manually trigger a RESYNC?

The RESYNC will run under 3 situations:
1. On every Sunday at 12:00pm (hoon)

2. When the replication module is enabled for the first time on the AhsayOBS (or after
it has been disabled for v5.0.1.7 or above)

3. When AhsayOBS startup after it has been shutdown abnormally

For newer versions of AhsayOBS (v5.0.1.7 or above), you can simply disable and re-enable
the replication module. However for older versions, if you really want to trigger a RESYNC,
here is a work-around:

1. Shutdown the AhsayOBS.

2 Edit [AhsayOBS Install Directory]\conf\lfsConfig.xml
3. Set clean-shutdown="N" under the Ifs tag.

4 Restart the AhsayOBS.

~Back to top
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5.7.

5.8.

5.9.

5.10.

5.11.

5.12.

How much data are being transfer during the RESYNC process?

The "weekly RESYNC" sends only UNSYNC data and it doesn't send all data again. It just
makes sure that all transaction logs are replicated with no errors.

In general, the RESYNC operation doesn't send data that exists on the replication server
already.

~Back to top
At times, replication takes a lot of CPU, why?

The replication process is CPU intensive, it involves checksum calculations and comparisons,
snapshot generation, transaction logging, disk 10, etc. So it is not abnormal to have a high
CPU utilization during the replication.

If you really want to restrain the CPU utilization as well as the bandwidth usage of the
replication process, you may try limiting the “Maximum Transfer Rate”.

~Back to top
The replication always stops abnormally during the process, why?

Please check if you have any antivirus or personal firewall software installed. Kindly disable
it from scanning the related data and traffic to see if the problem persists.

~Back to top
How up-to-date is the data on AhsayRPS?

When new files are uploaded to the AhsayOBS, the transaction log for the AhsayOBS is
amended, and this transaction log will be applied to the replication server when either the
transaction log is full or 5 minutes has lapsed, which ever is shorter. Therefore Data in
AhsayOBS and AhsayRPS will be out-of-SYNC by at most 5 minutes.

~Back to top
How do | copy files back from AhsayRPS to AhsayOBS?

The file structure under the [Home Directory] on AhsayRPS resembles that of the
corresponding AhsayOBS. To restore, you can simply transfer this file structure back to
appropriate location on the AhsayOBS machine.

~Back to top
What is the average speed for replication?

The followings are the data obtained from the replication speed test conducted using two
machines (for both AhsayOBS and AhsayRPS) running Intel Xeon 3.2GHz with 2GB of RAM
over a 2M/2M DSL line with both SSL and encryption enabled:

485 04:22:10 PM Replicating 'D:\OBS-Data\system\logfiles\log04b5.alf' (9.9M)
486 04:22:53 PM Replicating 'D:\OBS-Data\system\logfiles\log04b6.alf' (10M)
487 04:23:37 PM Replicating 'D:\OBS-Data\system\logfiles\log04b7.alf' (9.8M)
488 04:24:24 PM Replicating 'D:\OBS-Data\system\logfiles\log04b8.alf' (9.9M)
489 04:25:08 PM Replicating 'D:\OBS-Data\system\logfiles\log04b9.alf' (9.8M)
490 04:26:53 PM Replicating 'D:\OBS-Data\system\logfiles\logO4ba.alf' (9.9M)
491 04:27:48 PM Replicating 'D:\OBS-Data\system\logfiles\log04bb.alf' (9.9M)

The followings are the data we obtained from similar test over a 100MBit ethernet:

103 08:11:38 PM Replicating 'E:\Project\Testing\obs\v50\conf\rpsSend.xml.9" (929)
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104 08:11:38 PM Replicating
'E:\Project\Testing\obs\v50\webapps\obs\download\obm-linux.tar.gz' (38.5M)

105 08:12:29 PM Replicating
'E:\Project\Testing\obs\v50\webapps\obs\download\obm-mac.zip' (12M)

106 08:12:45 PM Replicating
'E:\Project\Testing\obs\v50\webapps\obs\download\obm-netware.zip' (6.7M)

107 08:12:54 PM Replicating
'E:\Project\Testing\obs\v50\webapps\obs\download\obm-solaris.tar.gz' (6.6M)

108 08:13:02 PM Replicating
'E:\Project\Testing\obs\v50\webapps\obs\download\obm-win.exe' (39.5M)

109 08:13:56 PM [End] Refreshing File

Total throughput of 837 MB/hour and 2.63 GB/hour for 2M/2M DSL and 100MBit LAN
ethernet respectively can be reached. If you are not getting close to this speed with similar
network and machine setup, please check your 1/0, network subsystem or CPU usage to see
if there is a bottleneck.

~Back to top

5.13. Can | use AhsayRPS to replicate/synchronize the files between the
servers?
It is not possible to do real time replication of files from one server to another. The replication
module is designed for AhsayOBS replication only and it cannot be used for generic

replication service between multiple servers.

~Back to top
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6. Common Error Messages

6.1. "Internal Error no. 1011" on the AhsayOBS Management Console

One license key can only be used to activate a single machine. Have you applied the license
key on another machine already? Or have you changed your network hardware? Please
shutdown the backup service on the first server that you have this license key installed. After
you have done this, please contact us at

http://kb.ahsay.com/index.php?_ m=tickets& a=submit&departmentid=3&step=1 and
kindly provide us with your "License Name" and "License Key", we will update the license
server to allow your key to be used again.

However, if you haven’t changed your hardware and are still getting this error, please check
whether you have any installed software that would create virtual MAC address in the system,
e.g. VPN software. If yes, please disable them, notify us to update your license, and update
your [Software License] page again.

~Back to top
6.2. "Activate Product Key Error"

If you are getting "Activate Product Key Error" when registering your license key on the
[Manage System] -> [Software License] page, please check the followings:

1. The backup server is connected to the internet and can connect to lic.ahsay.com
using HTTPS (port 443)

2. Both licensee name and license key are entered in exactly the same case (please
cut-and-paste both licensee name and license key to the text fields provided)

3. Check if the license file, [OBS Home]\conf\license.xml, is empty or corrupted. If yes,
delete it and reapply your license key in the AhsayOBS Management Console.

4. Check under [OBS Home]\conf to see if any of the configurations files (*.xml) is

empty or corrupted. If yes, delete those corrupted files and restart AhsayOBS.

If you are on Linux, please also check:

1. Whether you get any response by running "ping [your hostname]", if no, then please
add an entry for [your hostname] in the host file, e.g. /etc/hosts.

2. Run “ifconfig” and see if a valid "Ethernet HWaddr" is being displayed.
~Back to top
6.3. "Unable to send email Server=x.x.x.x", "Error sending alert email!!"

AhsayOBS is having problem in sending email via the SMTP server. Please try the followings:

1. Check if the SMTP service is running by using the command below:
“telnet x.xX.x.x 25”

2. Trigger a forgot-password email via [AhsayOBS Management Console]->[User
Login]->[Forgotten your password?] and see if any email get sent out

3. Ping the hostname of the AhsayOBS machine to see if it can be resolved into an IP
address, i.e. 'ping obs_hostname'. If not, then check if the host file contains a proper
entry for your hostname

4. In your SMTP server configuration, do you have email relay disabled for the OBS
machine? If so then it will need to be enabled in order for AhsayOBS to relay emails

5. Try pointing to another SMTP server.

6. If you are on Linux, please try setting the LD_ASSUME_KERNEL environment variable
in $OBS_HOME/bin/startup.sh by adding the following line and restart the OBS
service:

export LD_ASSUME_KERNEL=2.4.19

~Back to top
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6.4.

6.5.

6.6.

6.7.

6.8.

"Quota Exceeded"

This means that the backup account has run out of its allocated quota. Please contact your
administrator (or backup services provider) to increase your backup quota.

~Back to top
"Access is denied"

This means that the file is not accessible by AhsayOBM. Please check if the system account
that runs OBM has read access permission to the mentioned file.

~Back to top
"Checksum incorrect” / "Uploaded file size incorrect”

This error occurs when the backup file uploaded to the server is corrupted. Corrupted backup
files would not be stored on the backup server but will be uploaded to the backup server again
in the next backup job.

If more than one backup job of the same backup set is being run on more than one computer
at the same time, you might get this error. Please check if you have installed the client
software (AhsayOBM) with the same backup account on more than one computer.

Also, please check the file C:\Program Files\AhsayOBM\home.txt and see if you have more
than one “.obm” record (e.g. C:\Documents and Settings\Administrator\.obm) in this file
that refers to the same backup account on the server. If you can find such entries, simply
remove the redundant lines from this file and restart the computer.

Sometimes, this problem could be caused by network instability. If this only happens
occasionally, you can safely ignore this error.

~Back to top

"File 'obm-delta.tmp' does not exist on server" / "File
‘'obm-chksum.tmp’' does not exist on server”

For AhsayOBM v5.0.1.4 or before, please:
1. Upgrade your AhsayOBM to a newer version.

2. Delete the obm-delta.tmp or/and obm-chksum.tmp files from your “temporary
backup directory”, (e.g. C:\Backup\MSExchange\1137065709669).

For later versions of AhsayOBM, you can simply do step 2 to remove the problematic files
which were left behind during the backup operations of previous versions.

~Back to top
"Error getting report from all available IP addresses”

Please check if any of your disk partitions is full. Pay special attention to the AhsayOBS log
directory:

° Windows — C:\Program Files\Ahsay Offsite Backup Server\logs
° Linux — /usr/local/obs/logs
L] Mac OS X — /Applications/OBS/logs

It is safe to delete any log files here from the system.

Also, are you using non-default TCP port for the backup server? If so, please append the port
number of your HTTP (NOT HTTPS) connector to the [Manage System] -> [Host Name] entry,
e.g. backup.yourcompany.com:8080

If you are not using custom port, open a browser on the backup server and type in the value
of [Manage System] -> [Host Name] as an URL. Check if you get the backup server
homepage. If you cannot get the webpage, try altering the URL until you can reach the server.
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You can then put this value in the [Manage System] -> [Host Name] field. (Please omit the
page name, i.e. /index.jsp, from this entry)

If you are on Linux, please try setting the LD_ASSUME_KERNEL environment variable in
$0OBS_HOME/bin/startup.sh by adding the following line and restart the OBS service:

export LD_ASSUME_KERNEL=2.4.19

If you are running AhsayOBS on Linux Kernel 2.6, you could have run into the compatibility
problem of running Java program on Linux Kernel 2.6 (More info on:
http://www.jroller.com/page/dissonance/20050630#fedora_core_4 and_jdk)

Please try this to fix this problem:
1. Open $OBS_HOME/bin/startup.sh

2. Add “-Djava.net.preferlPv4Stack=true” to the command line argument. i.e. change
the line:
export CATALINA_OPTS="-Xms64m -Xmx512m -client
-Dsun.net.inetaddr.ttl=10800 -Dnetworkaddress.cache.ttl=10800
-Dsun.net.inetaddr.negative.ttl=0 -Dnetworkaddress.cache.negative.ttl=0"

to

export CATALINA_OPTS="-Xms64m -Xmx512m -client
-Dsun.net.inetaddr.ttl=10800 -Dnetworkaddress.cache.ttl=10800
-Dsun.net.inetaddr.negative.ttl=0 -Dnetworkaddress.cache.negative.ttl=0
-Djava.net.preferlPv4Stack=tru

3. Restart the backup service by running [$OBS_HOME/bin/shutdown.sh] and then
[$OBS_HOME/bin/startup.sh]

~Back to top
6.9. "C:\xxx\yyy\zzz.txt has been removed already"

There is latency between the backup agent with the list of files to be backed up and the time
these files are actually backed up. If any of these files are removed between this latency, an
informative message, “C:\xxx\yyy\zzz.txt has been removed already”, will be logged in the
backup log report. Under most condition, you don’t need to worry about this since files
created and then removed in this situation are usually temporary files. It is used by some
other applications and it is not necessary to backup these files.

If you are using Infile-Delta, please make sure “Temporary directory for storing backup files”
setting of your AhsayOBM is pointing a writable directory with plenty of disk space.

~Back to top

6.10. "The process cannot access the file because another process has
locked a portion of the file"

You get this message when backing up “C:\xxx\yyy\zzz.txt” because another application has
held a read-exclusive lock on “C:\xxx\yyy\zzz.txt”. The backup agent, therefore, is unable to
open the file to read its content. Please try the followings to resolve this problem:

° Enable the Volume Shadow Copy option for the corresponding backup set if you are
on Windows 2003 or XP.
L] If you are on an older version for Windows, you may need to obtain a generic “Open

File Manager” in order to backup the locked files.

° If the locked file is not important (e.g. C:\pagefile.sys), simply exclude the locked file
from your backup source. By doing so, this message will not appear again.

L] If the locked file is a database file held open by one of our supported applications (e.g.
Microsoft SQL Server, Microsoft Exchange Server, Oracle, Lotus Domino/Notes,
MySQL), simply use the corresponding add-on module provided to backup the
database. This way, you can backup the database you want (using the application
specific APIs) without accessing the database file directly.

L] If the locked file is a file held open by some other third party applications, you can use
the [Pre/Post Command Line Tool] to shutdown/restart the application that is locking
the file before/after a backup job to make sure that no locks will be placed on files
that you need to backup.
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~Back to top

6.11. "The process cannot access the file because it is being used by
another process”

This means that the file is currently locked by another process (or program). Please
shutdown the program locking this file before running the online backup program again. You
can also refer to “What do | have to do in order to backup open files” for more information (for
file backup set only).

~Back to top
6.12. "Premature end of input”

It means that the client software has problem downloading the list of files to be backed up
from the backup server. It then retries getting the list again. This is nothing to worry about.
AhsayOBM would log this as information rather than warning to avoid raising false alarm.

~Back to top

6.13. "Invalid XML Character" / "XML document structures must start
and end within the same entity"

Please try the followings:
1. Logon to the web interface of this backup account

2. Go to the [File Explorer] page and browse to the directory reported that contain this
problem (or some other directories)

3. Check if there are any filenames containing strange characters and delete them
4. Try backup again.

Also, please try increasing the "connectionTimeout" attribute within the "Connector" tag
inside [OBS Home]\conf\server.xml to a larger value (e.g. connectionTimeout="180000" or
connectionTimeout="600000"). This should help solve the problem.

~Back to top
6.14. "Incorrect Function"

Please check if you have any antivirus or personal firewall software installed. Kindly disable
it from scanning the related data and traffic to see if the problem persists.

~Back to top
6.15. "HTTP/1.1 502 Proxy Error"

The specified Secure Sockets Layer (SSL) port is not allowed. ISA Server is not configured to
allow SSL requests from this port. Most Web browsers use port 443 for SSL requests.
Refer to http://support.microsoft.com/kb/283284

~Back to top

6.16. " [Microsoft][ODBC SQL Server Driver][SQL Server]The statement
BACKUP LOG is not allowed while the recovery model is SIMPLE"

You need to change the Recovery model to FULL. If you are using Microsoft SQL Server
7.0/2000, please refer to the following screenshots:

1. http://download.ahsay.com/support/screenshots/SQL7-TuncateLogOnCheckpoint.j
pa
2. http://download.ahsay.com/support/screenshots/SQL2000-FullModel.jpg
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If you are using MSDE, please issue the following commands:
osgl -E -S [Server Name] -Q "ALTER DATABASE [Database Name] SET RECOVERY FULL"

These will enable transaction logging option for your MSDE databases and allow
incremental/differential backup to be run with no problems.

~Back to top

6.17. "CExBackup::backupService:HrESEBackupSetup: Error Number
0xc800020e: An incremental backup cannot be performed when
circular logging is enabled"

You need to disable circular logging in MS Exchange. Please uncheck the [Enable circular

logging] option as shown below and restart the “Microsoft Exchange Information Store”
service after you are done.

"E, Exchange System Manager !E‘ I
|J—% Console  Window  Help |;|i|1|
s v | & o EE | X 6 e |
Tree | WINZOOD e | Detais |
E Lebshama (Exchange) | |Mame 0

@ Global Settings [dProtacols B

@ Recipients @First Storage Group

-85 servers

=B winzooo
‘?IE\ Connectars
[+-42% Tools

]ﬂ Folders

Tranzaction log location:

Browse. .. |
IE:\Program Files\Exchzrvrmdbdata Browse... |

Log file prefis:
[E00

Sustem path location:

™ Zero out deleted database pages
T Enable circular logging
Don't enakle this option. Incremental backup cannot be performecd

wehen circular logging (ie. transaction logs are removed to reduce
the use of dizk space) is enabled.

QK I Cancel | Lol | Help
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6.18. "CExBackup::backupStorageGroup:HrESEBackupTruncatelLogs:
Error Number 0xc7ff1004: (null) "

This is an error returned by the Microsoft APl and is a Microsoft issue. Please try to restart the
"Microsoft Exchange Information Store” service. If the problem persists, you may want to
schedule the service to restart on a daily basis.

~Back to top
6.19. "CExBackup::backupStorageGroupLog:HrESEBackupGetLogAnd

PatchFiles: Error Number 0xc8000232: Some log or patch files are
missing"

If you have just disabled the MS Exchange circular logging option, please try running a full
backup again, this should fix the problem.

~Back to top
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6.20. "CExBackup::backupFile:WriteFile: Error Number Ox6: The handle
is invalid"

This is the MS Exchange having problem in writing to the Temporary spooling directory.
Please ensure that the system account running the MS Exchange has full access right to that
directory. If it is a network drive, please use an UNC path (e.g. \\server\share), and the
“Network Resources Authentication for Windows” is properly set for the corresponding
backup set.

~Back to top
6.21. "Path ‘C:\Temp\MSSQLServer\1137040769567’ does not exist"

If you get this error while you are doing MS SQL or MS Exchange backup, please try to use an
UNC path (e.g. //server/share) in "Temporary directory for storing backup files" under
[Backup Source Settings]. Please make sure that your OBM is on the same machine as your
MS SQL or MS Exchange. Please also ensure that you have included the appropriate
“Network Resources Authentication for Windows” information in the backup set.

For MS SQL Server, you may want to check whether if it can spool the database file correctly
by running the following command:

(Windows Authentication mode)
osql -E -Q "DECLARE @dbname char(64) SET @dbname = 'xxx' BACKUP DATABASE
@dbname TO DISK = '//server/share/abc.txt' WITH SKIP"

OR

(SQL Server Authentication mode)
osql -U USERNAME -P PASSWORD -Q "DECLARE @dbname char(64) SET @dbname = 'xxx’
BACKUP DATABASE @dbname TO DISK = '//server/share/abc.txt' WITH SKIP"

Note:
USERNAME/PASSWORD = the database username/password

xxX = the database that you would like to backup
//server/share/abc.txt = the location for the database spooling file

~Back to top

6.22. "Expectlog sequence 'xxx' but found 'SERVERNAME\Microsoft
Information Store\First Storage Group\EOOOxxx.log""

This occurs when the log sequence of MS Exchange was altered by other backup software, e.g.
NTBackup. Thus when the Backup Manager next performs a MS Exchange backup, the
Exchange log sequence would not match the one that it is expecting. With the broken
sequence, the Exchange server cannot be restored to its latest state.

To resolve this problem, you need to deactivate all other backup software that is operating on
MS Exchange, and then you need to perform a Full MS Exchange database backup manually
via the Backup Manager.

Alternatively, instead of backing up transaction logs during the weekdays, you can consider
doing Full Exchange Database backup on a daily basis with the In-File Delta option enabled.
This should avoid interference from other backup software while keeping the amount of
upload data to minimal.

~Back to top
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6.23. "The last backup jobs of *.stm (2006-10-30-13-40-21) and *.edb
(2006-11-04-03-05-00) don’t match for database 'ServerX\Microsoft
Information Store\First Storage Group\Mailbox Store (ServerX)™

For MS Exchange backup, *.stm and *.edb are backed up in pairs, if this error occurs, it
implies that during a previous backup, there was a problem with either the *.stm or *.edb file.
If this happens, please perform a Full MS Exchange backup manually via the Backup Manger
to resolve this problem.

~Back to top

6.24. "No *.stm found for database 'ServerX\Microsoft Information
Store\First Storage Group\Mailbox Store (ServerX)'™

This suggests that the .stm file on server may have been corrupted or found missing. To
resolve this error, please perform a Full MS Exchange backup manually via AhsayOBM.

~Back to top

6.25. Exception in thread "main" java.lang.UnsatisfiedLinkError:
lusr/local/lobm/jvm/lib/i386/libawt.so: libXp.s0.6: cannot open
shared object file: No such file or directory...

This is caused by a missing library in Fedora Core 6. To resolve this, just open a terminal window.
From here type in the command 'yum install libXp' (please note that the command is case sensitive), this
will ask you if it is ok to download the package. Just type 'Y' and the libXp library will be installed. Once
installed, just run the command

"sh $OBM_HOME/bin/RunBackupManager.sh"

You should find that the AhsayOBM will open up and you should be able to create the backup set via the
GUI interface.

When running the 'yun install' command, you may see the following error:

Loading "installonlyn" plugin
Existing lock /var/run/yum.pid: another copy is running. Aborting.

This is because the background YUM updater service is running. To stop it, run:
/etc/init.d/yum-updatesd stop

Once the process has been stop, you should be able to run the command 'yum install libXp' without any
problems.

~Back to top

**x End of FAQ ***

Ahsay Systems Corporation Limited Page 48 of 48 (May 22, 2009)



	1. General
	1.1. Can you briefly explain the idea of how the Ahsay Online Backup Software works?

	2. Branding (OEM Partners Only)
	2.1. Can we remove the name Ahsay in the AhsayOBM software? Can we put in our own company name/brand?
	2.2. Can I customize the desktop icon for AhsayOBM on the client machine?
	2.3. How do I customize the company logo for AhsayOBM Mac OS OEM version?

	3. Ahsay Online Backup Manager (AhsayOBM) / A-Click Backup (ACB)
	3.1. Can we customize the AhsayOBM? How can we change the name of the software, configuration, and auto-logon?
	3.2. What is the recommended bandwidth?
	3.3. How do I run AhsayOBM with Microsoft ISA 2004?
	3.4. How do I install AhsayOBM on FreeBSD?
	3.5. How do I install AhsayOBM on SCO Unix?
	3.6. How do I install AhsayOBM on AIX?
	3.7. The Windows version of AhsayOBM installer hangs, what could be the problem?
	3.8. The Installer doesn’t seem to work. How can I manually install AhsayOBM on Windows?
	3.9. The Installer doesn’t seem to work. How can I manually install AhsayOBM on Mac?
	3.10. Error occurred when Installing AhsayOBM on Novell.
	3.11. Are there any command line tools for AhsayOBM?
	3.12. How does AhsayOBM detect changes in files? Does it use the Archive bit? Some tape backup software resets the Archive bit. Would this affect AhsayOBM when backing up the same data?
	3.13. Does AhsayOBM copy the same set of files regularly?
	3.14. Transfer Block Size is 128Kb by default. Is there a reason for this?
	3.15. How can I backup a huge data set over the Internet?
	3.16. What is the best way to restore a huge data set?
	3.17. Does In-File Delta backup require a temporary working directory? 
	3.18. What is the average compression ratio?
	3.19. Can I change my encrypting key?
	3.20. If the “Use Login Password as Encrypting Key” option was selected when creating the backup set. Why I cannot restore the backup data with my most current login password?
	3.21. What kind of encryption used by AhsayOBM?
	3.23. Scheduled backup jobs are not running on my Windows machine, why?
	3.24. I am having problems with my scheduled backup, why?
	3.25. I cannot get proxy authentication to work with AhsayOBM, why?
	3.26. Can I backup an entire Operating System?
	3.27. When setting up a Microsoft SQL Backup Set, I cannot list the available SQL servers, what can I do?
	3.28. Why are the Microsoft SQL Server databases missing from the backup source list? 
	3.29. How to set the recovery model of a MS SQL database to FULL?
	3.30. Windows network map drive connections are not stable, why?
	3.31. There is an error when backing up files on a remote NetWare server, what can I do?
	3.32. What are the advantages and disadvantages of backing up multiple computers using a single backup account? 
	3.33. How to find out which version of the client software the user is using? 
	3.34. Does the AhsayOBM upgrade the installation of Java on a client machine, or does it install a separate copy for its own use? 
	3.35. After upgrading AhsayOBS, do I have to upgrade all the AhsayOBM as well? And do I need to transform/migrate their current data?
	3.36. Is it possible to do incremental or differential backups with MySQL?
	3.37. How does the “Remove retention files for overlap policy” under Advanced Retention Policy work?
	3.38. What is incremental backup and how does In-File Delta work?
	3.39. How does the “Auto” block size work under In-file Delta settings?
	3.40. What happens when we do In-File Delta backup on a directory?
	3.41. Does AhsayOBM have to stop the application when doing online backups?
	3.42. What are Off-line backup, Logout backup reminder and Local backup features?
	3.43. Why is my AhsayOBM running backup once every hour?
	3.44. How do I disable “logout backup reminder”?
	3.45. How do I upgrade AhsayOBM from V4.5 on Linux?
	3.46. How do I change the .obm path for Novell? 
	3.47. The MS SQL or MS Exchange database backup job stores 2 copies of the spooled database file in the "temporary directory" (tagged with different datetimes). This has taken up extra disk space, is this necessary? 
	3.48. What do I have to do in order to backup open files?

	4. Ahsay Offsite Backup Server (AhsayOBS)
	4.1. What is the recommended hardware and Operating System (Windows or Linux) for AhsayOBS?
	4.2. What is the recommended bandwidth?
	4.3. Is there a limit on the number of clients that an AhsayOBS can support? How many clients would you recommend per AhsayOBS?
	4.4. What is the limit on file size that AhsayOBS can backup?
	4.5. How many users/licenses can I have on one server?
	4.6. The Installer doesn’t seem to be working. How can I manually install AhsayOBS on Windows?
	4.7. How do I install AhsayOBS on FreeBSD?
	4.8. How to install AhsayOBS if ports 80 and 443 are already taken by other applications?
	4.9. The AhsayOBS doesn’t seem to work, is this related to the Microsoft Internet Information Server (IIS) running on the same server? 
	4.10. Is the 128-bit SSL secure enough to communication between AhsayOBM and AhsayOBS?
	4.11. How is the data privacy being maintained on AhsayOBS?
	4.12. How do I install a SSL certificate?
	4.13. I am getting a “Failed to establish chain from reply” error when trying to import a SSL certificate, why?
	4.14. Can we customize the AhsayOBS? 
	4.15. Can we customize the contents of the AhsayOBS Management Console as well as those of the email reports and reminders?
	4.16. Can we customize the layout of the email sent to customers?
	4.17. What is the purpose of the Retention area, can I disable it?
	4.18. Is there an example on how the Retention area works?
	4.19. Is it possible to keep 5 years backup, if so, do I need to set the retention policy to 1825 days?
	4.20. Unmodified files are not uploaded to OBS regularly. Is this acceptable?
	4.21. Can I increase the quota of Trial accounts on my AhsayOBS?
	4.22. How can I stop a running backup job from AhsayOBS?
	4.23. AhsayOBS is not functioning properly, backup jobs stop in the middle of the process, why?
	4.24. After a seed copy, the disk space used is not reflected in the user statistics on AhsayOBS. Do I need to manually update the OBS statistics?
	4.25. Is there a tool to verify integrity of the backup data on AhsayOBS?
	4.26. How do I backup an AhsayOBS?
	4.27. How do I rebuild OBS from a backup?
	4.28. How do I move backup data to a new AhsayOBS?
	4.29. What do I have to do when changing the IP address of the AhsayOBS?
	4.30. How do I move an AhsayOBS installation from one directory to another directory (Windows)?
	4.31. How do I move my AhsayOBS to a new server?
	4.32. How do I move users between different “User Homes”?
	4.33. How do I rename a backup account on AhsayOBS?
	4.34. Can I change the Backup Client type between AhsayACB User and AhsayOBM User?
	4.36. Backup accounts on my AhsayOBS are disappearing, why?
	4.37. When trying to setup AhsayOBS on Windows with the “User Homes” pointing to an external NAS device. It says “Access denied” when try to create a new user account. What can I do?
	4.38. The [Backup Job] drop down menu on the [Report] page from the AhsayOBS Management Console is showing an empty list. What can I do?
	4.39. Why do I receive multiple reports from the same backup job on AhsayOBS Management Console?
	4.40. How do I setup AutoUpgrade?
	4.41. My clients have auto-upgraded to a wrong AhsayOBM, how could I force another AutoUpgrade?
	4.42. Why do I have problem in restoring through the restorer applet on the OBS Management Console?
	4.43. Why do I have problem in restoring large amount of files through the restorer applet on the AhsayOBS Management Console?
	4.44. How do I sign the restorer applet on my customized AhsayOBS?
	4.45. How do I remove pending emails from AhsayOBS?
	4.46. Is there any documentation on the APIs?
	4.47. Why do I have problem in License activation/Report sending? It gives “Invalid argument or cannot assign requested address” error message.

	5. Ahsay Replication Server (AhsayRPS)
	5.1. How does AhsayRPS work?
	5.2. How should I configure my AhsayRPS-AhsayOBS pair?
	5.3. I have a large amount of data to be replicated to AhsayRPS, is there a Seed Load facility for AhsayOBS? 
	5.4. Is there a method to avoid replicating the moved “User Home” to AhsayRPS all over again? 
	5.5. My replication pair is not working, what can I do?
	5.6. How can I manually trigger a RESYNC?
	5.7. How much data are being transfer during the RESYNC process?
	5.8. At times, replication takes a lot of CPU, why?
	5.9. The replication always stops abnormally during the process, why?
	5.10. How up-to-date is the data on AhsayRPS?
	5.11. How do I copy files back from AhsayRPS to AhsayOBS?
	5.12. What is the average speed for replication?
	5.13. Can I use AhsayRPS to replicate/synchronize the files between the servers?

	6. Common Error Messages
	6.1. "Internal Error no. 1011" on the AhsayOBS Management Console
	6.2. "Activate Product Key Error"
	6.3. "Unable to send email Server=x.x.x.x", "Error sending alert email!!"
	6.4. "Quota Exceeded" 
	6.5. "Access is denied" 
	6.6. "Checksum incorrect" / "Uploaded file size incorrect"
	6.7. "File 'obm-delta.tmp' does not exist on server" / "File 'obm-chksum.tmp' does not exist on server"
	6.8. "Error getting report from all available IP addresses"
	6.9. "C:\xxx\yyy\zzz.txt has been removed already" 
	6.10. "The process cannot access the file because another process has locked a portion of the file" 
	6.11. "The process cannot access the file because it is being used by another process" 
	6.12. "Premature end of input" 
	6.13. "Invalid XML Character" / "XML document structures must start and end within the same entity"
	6.14. "Incorrect Function" 
	6.15. "HTTP/1.1 502 Proxy Error" 
	6.16. " [Microsoft][ODBC SQL Server Driver][SQL Server]The statementBACKUP LOG is not allowed while the recovery model is SIMPLE"
	6.17. "CExBackup::backupService:HrESEBackupSetup: Error Number 0xc800020e: An incremental backup cannot be performed when circular logging is enabled"
	6.18. "CExBackup::backupStorageGroup:HrESEBackupTruncateLogs: Error Number 0xc7ff1004: (null) "
	6.19. "CExBackup::backupStorageGroupLog:HrESEBackupGetLogAndPatchFiles: Error Number 0xc8000232: Some log or patch files are missing"
	6.20. "CExBackup::backupFile:WriteFile: Error Number 0x6: The handle is invalid" 
	6.21. "Path ‘C:\Temp\MSSQLServer\1137040769567’ does not exist"
	6.22. "Expect log sequence 'xxx' but found 'SERVERNAME\Microsoft Information Store\First Storage Group\E000xxx.log'"
	6.23. "The last backup jobs of *.stm (2006-10-30-13-40-21) and *.edb (2006-11-04-03-05-00) don’t match for database 'ServerX\Microsoft Information Store\First Storage Group\Mailbox Store (ServerX)'"
	6.24. "No *.stm found for database 'ServerX\Microsoft Information Store\First Storage Group\Mailbox Store (ServerX)'"
	6.25. Exception in thread "main" java.lang.UnsatisfiedLinkError: /usr/local/obm/jvm/lib/i386/libawt.so: libXp.so.6: cannot open shared object file: No such file or directory…


